Видеоуроки
Interface
Essentials
Advanced
Полезные советы
Принципы работы
Свойства (properties)
Компонентная Система
Рендер
Физика
Редактор UnigineEditor
Обзор интерфейса
Работа с ассетами
Настройки и предпочтения
Работа с проектами
Настройка параметров узла
Setting Up Materials
Setting Up Properties
Освещение
Landscape Tool
Sandworm (Experimental)
Использование инструментов редактора для конкретных задач
Extending Editor Functionality
Программирование
Основы
Настройка среды разработки
Примеры использования
UnigineScript
C++
C#
Унифицированный язык шейдеров UUSL
File Formats
Rebuilding the Engine Tools
GUI
Двойная точность координат
API
Containers
Common Functionality
Controls-Related Classes
Engine-Related Classes
Filesystem Functionality
GUI-Related Classes
Math Functionality
Node-Related Classes
Objects-Related Classes
Networking Functionality
Pathfinding-Related Classes
Physics-Related Classes
Plugins-Related Classes
IG Plugin
CIGIConnector Plugin
Rendering-Related Classes
Работа с контентом
Оптимизация контента
Материалы
Art Samples
Tutorials

Переход на UNIGINE с Unity

This section gives a brief overview of UNIGINE from a Unity user's perspective and provides basic information to help you transfer your Unity experience to UNIGINE.Этот раздел дает краткий обзор UNIGINE с точки зрения пользователя Unity и предоставляет основную информацию, которая поможет вам перенести ваш опыт работы с Unity на UNIGINE.

Примечание
Please consider hardware requirements first.Пожалуйста, сначала ознакомьтесь с требованиями к оборудованию .

Quick GlossaryБыстрый глоссарий#

This chapter matches common Unity software terms on the left and their UNIGINE equivalents (or rough equivalent) on the right. UNIGINE keywords are linked directly to related articles to provide you with more in-depth information.Эта глава сопоставляет общие программные термины Unity слева и их эквиваленты UNIGINE (или приблизительный эквивалент) справа. Ключевые слова UNIGINE напрямую связаны со связанными статьями, чтобы предоставить вам более подробную информацию.

CategoryUnity softwareUNIGINE
Project and SDK managementHubSDK Browser
Editor UIHierarchy PanelWorld Nodes Hierarchy window
InspectorParameters window
Project BrowserAsset Browser window
Scene ViewEditor Viewport
SceneSceneWorld
Gameplay TypesComponentComponent System
GameObjectNode
PrefabNodeReference
MeshesMesh RendererStatic Mesh, Dynamic Mesh
Skinned Mesh RendererSkinned Mesh
BlendshapesMorph Targets
EffectsParticle SystemParticle System
HaloVolumetric Objects
Lens FlaresLens Flares
Billboard RendererBillboards
Projector / Decal Projector (HDRP)Decals
ExteriorsTerrainTerrain systems
Trees / GrassMesh Clutter, Grass, Vegetation Add-On
Wind ZonesAnimation Field
Game UIUIGUI
LightingLight SourcesLight Sources
EnvironmentEnvironment
LightmappingVoxel GI
Reflection ProbesEnvironment Probes
RenderingShaderBase Material
MaterialUser Material
Custom Shaders: HLSL, Shader GraphHLSL / GLSL / UUSL
Compute ShadersUUSL Compute Shaders
Rendering PathsRendering Sequence
Multi-Display RenderingMulti-Monitor Rendering plugins, Syncker Plugin for Multi-Node Rendering
ProgrammingC#C++ / C#
Scriptable Render Pipeline (URP / HDRP)Rendering Sequence if fully accessible from API / Scriptable Materials
PhysicsRaycastIntersections
Rigid BodyRigid Body
ColliderShape
JointJoint
ClothCloth Body
AnimationTimelineTracker
Navigation and PathfindingNavMesh, NavMeshAgent, Off-Mesh Link, NavMesh ObstacleNavigation Areas, Obstacles

Project and SDK ManagementУправление проектами и SDK#

As a Unity software user, you are accustomed to use Unity Hub — the application that streamlines the way you find, download and manage your projects and installations.Как пользователь программного обеспечения Unity, вы привыкли использовать Unity Hub - приложение, которое упрощает поиск, загрузку и управление вашими проектами и установками.

UNIGINE SDK Browser is the first step to start working with UNIGINE Engine. This application enables you to manage your projects and installed SDKs, as well as gives you access to the samples and the knowledge base. Браузер UNIGINE SDK - это первый шаг к началу работы с UNIGINE Engine. Это приложение позволяет управлять своими проектами и установленными SDK, а также предоставляет доступ к примерам и базе знаний.

Сравнение Unity Hub и UNIGINE SDK Browser (нажмите, чтобы увеличить)

Сравнение Unity Hub и UNIGINE SDK Browser

UNIGINE provides several programming workflows, to easily adapt your experience of scripting in Unity software, it is recommended to use C# Component System. Creating a project using this workflow in SDK Browser is done as follows:UNIGINE предоставляет несколько рабочих процессов программирования , чтобы легко адаптировать ваш опыт написания сценариев в программном обеспечении Unity, рекомендуется использовать C# Component System . Создание проекта с использованием этого рабочего процесса в SDK Browser выполняется следующим образом:

  1. Click Create New in My Projects sectionНажмите Create New в разделе My Projects
  2. Among other options, choose C# (.NET Core) project type in the API + IDE field.Среди других опций выберите тип проекта C# (.NET Core) в поле API + IDE.
  3. If you want to make the project compatible with one of supported VR headsets, proceed to the Plugins section, check the required plugins in the Stereo 3D section and click Ok (more about VR-compatibility).Если вы хотите сделать проект совместимым с одной из поддерживаемых VR-гарнитур, перейдите в раздел Plugins, отметьте необходимые плагины в разделе Stereo 3D и нажмите Ok (подробнее о VR-совместимости ).
  4. Click Create New Project.Щелкните Create New Project.
  5. Upon completion, click Open Editor to run UnigineEditor.По завершении щелкните Open Editor, чтобы запустить UnigineEditor.
Примечание
C# API section available in the Samples showcases traditional programming workflow in C#. For samples that use C# Component System, take a look at the Demos -> C# Component Samples.Раздел C# API , доступный в Samples , демонстрирует традиционный рабочий процесс программирования на C#. Примеры, в которых используется C # Component System , можно найти в файле Demos -> C# Component Samples.

Editor InterfaceИнтерфейс редактора#

Below you can see interfaces of Unity Editor and UnigineEditor. Interface elements in the images are color-coded to indicate common functionality. Each element has a label to show UNIGINE's equivalent. The layout of UnigineEditor is fully customizable by resizing, dragging and dropping the tabbed windows. UnigineEditor adopts a dark color scheme.Ниже вы можете увидеть интерфейсы Unity Editor и UnigineEditor. Элементы интерфейса на изображениях имеют цветовую кодировку для обозначения общих функций. Каждый элемент имеет метку для отображения эквивалента UNIGINE. Макет UnigineEditor полностью настраиваемый путем изменения размера, перетаскивания окон с вкладками. UnigineEditor использует темную цветовую схему.

Сравнение пользовательского интерфейса редакторов Unity и UnigineEditor (нажмите, чтобы увеличить)

Unity Editor and UnigineEditor UI ComparisonСравнение пользовательского интерфейса редакторов Unity и UnigineEditor

To learn more about the UnigineEditor interface, read this article.Чтобы узнать больше об интерфейсе UnigineEditor, прочтите эту статью .

Scene ViewScene View#

You may find the Scene View and the Editor Viewport controls looking very much alike.Вы можете обнаружить, что элементы управления Scene View и Editor Viewport очень похожи.

Unity Scene View
UNIGINE Editor Viewport

You can use:Вы можете использовать:

  • Camera panel to switch between cameras and configure the current one.Camera panel для переключения между камерами и настройки текущей.
  • Rendering Debug to display the contents of rendering buffers the same way as using the Draw Mode in Unity Editor.Rendering Debug для отображения содержимого буферов рендеринга так же, как при использовании Draw Mode в Unity Editor.
  • Navigation panel to quickly set up and switch between camera speed presets and change the camera position.Navigation panel для быстрой настройки и переключения между предустановками скорости камеры и изменения положения камеры.

Navigation inside the Editor Viewport is pretty much the same as in Unity Scene View. However, get familiar with Scene Navigation so as not to miss details. Навигация внутри Editor Viewport почти такая же, как и в Unity Scene View. Однако ознакомьтесь с навигацией по сценам , чтобы не упустить детали.

Also, a set of global switchers is available in the top toolbar:Также на верхней панели инструментов доступен набор глобальных переключателей:

You can use as many Editor Viewports as you need.Вы можете использовать столько окон просмотра редактора , сколько вам нужно.

Game View and Play ModeПросмотр игры и режим игры#

You are accustomed that Unity Editor has the Play mode inside the Game View which is rendered from the camera(s) in your scene, being representative of your final build.Вы привыкли, что в редакторе Unity есть режим Play внутри Game View, который рендерится с камеры (камер) в вашей сцене, представляя вашу окончательную сборку.

In UNIGINE, the Play button is used to run an instance of the application in a separate window. You can switch between Play presets to change essential parameters of the play mode, such as VR Mode to enable compatibility with one of supported VR headsets, as an example.В UNIGINE кнопка Play используется для запуска экземпляра приложения в отдельном окне. Вы можете переключаться между предустановками Play, чтобы изменить основные параметры режима воспроизведения, например, VR Mode, чтобы включить совместимость с одной из поддерживаемых гарнитур VR.

By default, the mouse cursor is grabbed when clicked in the Play mode. There are two ways to setup default Input Bindings (key states and the mouse behaviour):По умолчанию курсор мыши захватывается при нажатии в режиме Play. Есть два способа установить привязки ввода по умолчанию (состояния клавиш и поведение мыши):

Примечание
The Engine Viewport, the Game View's counterpart in UNIGINE used for debugging and profiling, is considered excessive for projects using C# .NET Core programming workflow (however, it is still available for other workflows).Engine Viewport, аналог Game View's в UNIGINE, используемый для отладки и профилирования, считается избыточным для проектов, использующих рабочий процесс программирования C # .NET Core (однако он по-прежнему доступен для других рабочих процессов).

ConsoleКонсоль#

As well as Unity software, UNIGINE has the Console used for standard input, output and error logging. A set of console commands is provided.Помимо программного обеспечения Unity, UNIGINE имеет Console , используемую для стандартного ввода, вывода и регистрации ошибок. Предоставляется набор консольных команд .

It is available both in UnigineEditor and a running application. To open the Console window in the Editor, go to Windows -> Console menu:Он доступен как в UnigineEditor, так и в работающем приложении. Чтобы открыть окно консоли в редакторе, перейдите в меню Windows -> Console:

A built-in console is called by pressing the grave accent (`) key:Встроенная консоль вызывается нажатием клавиши grave accent (`):

You can use it to print user messages from code.Вы можете использовать его для печати пользовательских сообщений из кода .

Building a ProjectСоздание проекта#

You got used to building your projects via Unity Editor. In UNIGINE, building a project is also done via UnigineEditor.Вы привыкли создавать свои проекты через редактор Unity. В UNIGINE создание проекта также выполняется через UnigineEditor.

Projects and FilesПроекты и файлы#

Directories and FilesКаталоги и файлы#

A project in UNIGINE, just like a Unity project, is stored in its own folder, project settings are stored in the *.project file. There are various subfolders inside the project's folder, where your content and source files as well as various configuration files and binaries are stored. The most important are the data and source sub-folders.Проект в UNIGINE, как и проект Unity, хранится в своей собственной папке, настройки проекта хранятся в файле *.project. Внутри папки проекта есть различные подпапки, в которых хранятся ваш контент и исходные файлы, а также различные файлы конфигурации и двоичные файлы. Наиболее важными из них являются подпапки данные и источник .

In UNIGINE, each project has a data folder. Similar to a Unity project's Assets folder, this is where your project's assets are stored. To import assets into your project, simply drop files into your project's data directory and they will be automatically imported and appear in the Asset Browser. The assets in the editor will update automatically as you make changes to the files using an external program.В UNIGINE у каждого проекта есть папка data. Подобно папке Assets проекта Unity, здесь хранятся ассеты вашего проекта. Чтобы импортировать ассеты в проект, просто перетащите файлы в каталог проекта data, и они будут автоматически импортированы и появятся в Asset Browser . Ассеты в редакторе обновляются автоматически, когда вы вносите изменения в файлы с помощью внешней программы.

Relationship between the contents of the data folder in your project's root on your computer, and the Project folder in the Asset Browser windowВзаимосвязь между содержимым папки data в корне вашего проекта на вашем компьютере и папкой Project в окне Asset Browser

Supported File TypesПоддерживаемые типы файлов#

Unity software supports a wide range of file formats, while UNIGINE supports the most commonly used and some specific ones:Unity поддерживает широкий спектр форматов файлов, а UNIGINE поддерживает наиболее часто используемые и некоторые специфические :

Типы ассетов Поддерживаемые форматы
Геометрия .fbx, .obj, .3ds, .dae, .glb/.gltf, .stp/.step, .igs/.iges, .brep, .stl
Текстуры .png, .jpeg, .tif, .tga, .rgba, .psd, .hdr, .dds, and more
Звук и видео .wav, .mp3, .oga/.ogg, .ogv
Шрифты .ttf

Bringing Your Assets from Unity SoftwareПеренос ассетов из Unity#

Примечание
If you import a group of assets containing .meta description files (for example, from a Unity project), there mights be warnings in the Console due to unsupported file format. Upon import completion, all contents in .meta files in the UNIGINE project folder will be replaced with UNIGINE native asset metadata. Source files will not be affected.Если вы импортируете группу ассетов, содержащих файлы описания .meta (например, из проекта Unity), в Console могут появиться предупреждения из-за неподдерживаемого формата файла. По завершении импорта все содержимое файлов .meta в папке проекта UNIGINE будет заменено собственными метаданными ассетов UNIGINE. Исходные файлы не пострадают.

Meshes Меши

You can import an asset you used in Unity software to UNIGINE if you have it as an FBX model. While importing the FBX model to UNIGINE, check the required import options depending on the model.Вы можете импортировать ассет, который вы использовали в программном обеспечении Unity, в UNIGINE, если он у вас есть как модель FBX. При импорте модели FBX в UNIGINE проверьте необходимые параметры импорта в зависимости от модели.

UNIGINE uses the same units (meters) as Unity software, so you don't need to rescale meshes.UNIGINE использует те же единицы (метры), что и программное обеспечение Unity, поэтому вам не нужно изменять масштаб мешей.

Materials Материалы

Similar to Unity software, UNIGINE works with PBR materials and supports both Metalness and Specular workflows (similar to Unity materials based on the Standard and Standard (Specular Setup) shaders), a rich out-of-the-box library of materials enables to create almost any material. So, materials created for the model in Unity software can be re-created in UNIGINE using mesh_base material, the base material in UNIGINE used for physically based materials.Подобно программному обеспечению Unity, UNIGINE работает с PBR-материалами и поддерживает рабочие процессы Metalness и Specular (аналогично материалам Unity на основе шейдеров Standard и Standard (Specular Setup)). Коробочная библиотека материалов позволяет создавать практически любые материалы. Таким образом, материалы, созданные для модели в программном обеспечении Unity, могут быть воссозданы в UNIGINE с использованием материала mesh_base, базового материала в UNIGINE, используемого для физически обоснованных материалов.

Textures Текстуры

Textures can be imported as a part of a model or separately and then applied to a mesh. To import textures, you might have to do some adjustments in advance. For example, the Shading texture in UNIGINE stores the metalness, roughness, specular, and microfiber maps in its corresponding channels, so you need to modify the texture using third-party software, such as GIMP or Photoshop, and then import it to UNIGINE.Текстуры можно импортировать как часть модели или отдельно, а затем применять к сетке. Чтобы импортировать текстуры , вам, возможно, придется заранее внести некоторые изменения. Например, текстура Shading в UNIGINE хранит карты металличности, шероховатости, отражения и микрофибры в соответствующих каналах, поэтому вам необходимо изменить текстуру с помощью стороннего программного обеспечения, такого как GIMP или Photoshop, а затем импортировать ее в UNIGINE.

To import the Normal texture, you should invert the G channel. This can be done while importing the texture (or even later) by using the Invert G Channel setting.Чтобы импортировать текстуру Normal, вы должны инвертировать G-канал. Это можно сделать при импорте текстуры (или даже позже) с помощью параметра Invert G Channel.

Animations Анимация

You can import a bone-animated model you used in Unity software to UNIGINE if you have it as an FBX model. While importing the FBX model, enable the Import Animations option and fine-tune the import using additional options.Вы можете импортировать модель с анимацией костей, которую вы использовали в программе Unity, в UNIGINE, если она у вас есть как модель FBX. При импорте модели FBX включите параметр Импорт анимации и настройте импорт с помощью дополнительных параметров.

For more details, see import recommendations.Для получения дополнительных сведений см. рекомендации по импорту .

SceneСцена#

The concept of the Scene in both engines is the same. However, Unity software and UNIGINE use different coordinate systems.Концепция сцены в обоих движках одинакова. Однако программное обеспечение Unity и UNIGINE используют разные системы координат.

Unity softwareUNIGINE

Unity Coordinate System (left-handed)

Unity software uses a left-handed coordinate system where the vertical direction is usually represented by the +Y axis.Программа Unity использует левостороннюю систему координат, в которой вертикальное направление обычно представлено осью +Y.

One unit is one meter.Один unit - один метр.

Axes and Directions: Оси и направления:

  • X — right (+), left (-) X - вправо (+), влево (-)
  • Y — up (+), down (-) Y - вверх (+), вниз (-)
  • Z — forwards (+), backwards (-) Z - вперед (+), назад (-)

Positive rotation angle sets the rotation clockwise.Положительный угол поворота устанавливает вращение по часовой стрелке.

File format: *.sceneФормат файла: *.scene

UNIGINE Coordinate System (right-handed)

UNIGINE uses a right-handed coordinate system where the vertical direction is usually represented by the +Z axis.UNIGINE использует правостороннюю систему координат, в которой вертикальное направление обычно представлено осью +Z.

One unit is one meter.Один unit - один метр.

Axes and Directions: Оси и направления:

  • X — right (+), left (-) X - вправо (+), влево (-)
  • Y — forwards (+), backwards (-) Y - вперед (+), назад (-)
  • Z — up (+), down (-) Z - вверх (+), вниз (-)

Positive rotation angle sets the rotation counterclockwise.Положительный угол поворота устанавливает вращение против часовой стрелки.

File format: *.worldФормат файла: *.world

Scene ObjectsОбъекты сцены#

This section gives a brief description of basic scene objects in both engines as well as their basic similarities and differences.В этом разделе дается краткое описание основных объектов сцены в обоих движках, а также их основные сходства и различия.

Unity softwareUNIGINE

Hierarchy windowОкно иерархии


Basic scene object — GameObject.

Базовый объект сцены - GameObject.

GameObjects are containers for all other Components. Components add functionality to the GameObject.

GameObject - это контейнеры для всех остальных компонентов. Компоненты добавляют функциональности GameObject.

Every GameObject has the Transform component by default.
Каждый GameObject по умолчанию имеет компонент Transform.

GameObjects can be organized into a hierarchy (parent-child relation).GameObject может быть организован в иерархию (отношение родитель-потомок).

World Nodes Hierarchy windowОкно иерархии мировых узлов


Node is a basic type from which all types of scene objects are inherited. Some of them appear visually: Objects, Decals, and Effects — they all have surfaces to represent their geometry (mesh), while others (Light Sources, Players, etc.) are invisible.

Node - это базовый тип, от которого наследуются все типы объектов сцены. Некоторые из них выглядят визуально: Objects , Decals и Effects - все они имеют поверхности для представления их геометрии (сетка), а другие ( Источники света , Плееры и т.д.) невидимы.

Basic functionality of a node is determined by its type. Additional functionality can be added using properties and a component system.Базовая функциональность узла определяется его типом. Дополнительные функции можно добавить с помощью свойств и системы компонентов .

Each node has a transformation matrix, which encodes its position, rotation, and scale in the world.У каждого узла есть матрица преобразования, которая кодирует его положение, поворот и масштаб в мире.

Nodes can be organized into a hierarchy (parent-child relation).Узлы могут быть организованы в иерархию (отношения родитель-потомок).

Примечание
All scene objects added to the scene regardless of their type are called nodes.Все объекты сцены, добавленные в сцену, независимо от их типа, называются узлами.

PrefabsСборные#

The workflow in Unity software is based on prefabs. It is usual for you to assemble a complex object from GameObjects with certain components and properties and create a prefab from such object. Prefabs can then be placed in your world via Editor, or instantiated at run time.Рабочий процесс в программе Unity основан на сборных. Обычно вы собираете сложный объект из GameObjects с определенными компонентами и свойствами и создаете префаб из такого объекта. Затем префабы могут быть размещены в вашем мире через редактор или созданы во время выполнения.

UNIGINE's workflow is based on Node References that are very similar to prefabs. In order to make a complex object to be instanced in your world, you just build the desired hierarchy from nodes, assign materials and properties to them, and save it as a Node Reference. Then you can use this node reference as many times as necessary and, just like with the prefabs, modify the node reference by changing any of its instances.Рабочий процесс UNIGINE основан на ссылках на узлы , которые очень похожи на префабы. Чтобы сделать сложный объект экземпляром в вашем мире, вы просто создаете желаемую иерархию из узлов, назначаете им материалы и свойства и сохраняете ее как Node Reference. Затем вы можете использовать этот node reference столько раз, сколько необходимо, и, как и в случае с префабами, изменить node reference, изменив любой из его экземпляров.

Примечание
Node References support nesting as well, so you can build complex hierarchies easily.Ссылки на узлы также поддерживают вложение, поэтому вы можете легко создавать сложные иерархии.

To learn more about creating Node References and managing them, please follow the link below:Чтобы узнать больше о создании ссылок на узлы и управлении ими, перейдите по ссылке ниже:

How to Collaborate?Организация совместной работы#

Unity Editor provides the Smart Merge tool and support for custom tools for resolving conflicts when merging results of teamwork. Scenes and other files should use the YAML format in order to be merged.Unity Editor предоставляет инструмент Smart Merge и поддержку пользовательских инструментов для разрешения конфликтов при слиянии результатов совместной работы. Сцены и другие файлы должны использовать формат YAML для объединения.

In UNIGINE, all native file formats are text-based by default, so you can use any VCS you are used to and merge worlds, nodes and other assets. You can extend the file system to keep the shared assets by using Mount Points. Also, a normal workflow is to split work of different team members using separate Node Layers, so there will be no need to match the conflicted files when merging the project modifications.В UNIGINE все собственные форматы файлов по умолчанию основаны на тексте, поэтому вы можете использовать любую VCS , к которой вы привыкли, и объединять миры, узлы и другие ресурсы. Вы можете расширить файловую систему, чтобы сохранить общие ресурсы, используя точки монтирования . Кроме того, обычным рабочим процессом является разделение работы разных членов команды с использованием отдельного Node Layers, поэтому не будет необходимости сопоставлять конфликтующие файлы при объединении изменений проекта.

Check out the related article for more details:Ознакомьтесь с соответствующей статьей для получения более подробной информации:

CamerasКамеры#

Cameras, the entities essential for rendering, are treated slightly differently in both engines. Камеры , сущности, необходимые для рендеринга, обрабатываются в обоих движках немного по-разному.

In Unity software, Camera component is responsible for capturing a view and sending it to render. All enabled cameras present in the scene are rendered in the viewport (Game View) and may overlap each other. To switch between cameras, one usually needs to toggle off the current camera and enable the other one.В программном обеспечении Unity компонент Camera отвечает за захват представления и отправку его на рендеринг. Все включенные камеры, присутствующие в сцене, отображаются в окне просмотра (Game View) и могут перекрывать друг друга. Чтобы переключаться между камерами, обычно необходимо выключить текущую камеру и включить другую.

In UNIGINE, the Camera is a rendering-related object and implemented by the Player nodes in the world. There are several player types with different behaviour provided in order to simplify creation of the most commonly used cameras controlled via the input devices (keyboard, mouse, joystick):В UNIGINE Камера - это объект, связанный с визуализацией, который реализуется узлами Player в мире. Предусмотрено несколько типов игроков с различным поведением, чтобы упростить создание наиболее часто используемых камер, управляемых через устройства ввода (клавиатура, мышь, джойстик):

  • Dummy is a simple camera wrapper. You can use it for static cameras or enhance with custom logic. Dummy - это простая оболочка камеры. Вы можете использовать его для статических камер или улучшить с помощью настраиваемой логики.
  • Spectator is a free flying camera. Spectator - это бесплатная летающая камера.
  • Persecutor is a flying camera that has the target and orbits it at the specified distance. It is a ready-to-use simple solution for a third-person camera. Persecutor - это летающая камера, которая имеет цель и вращается вокруг нее на указанном расстоянии. Это готовое простое решение для камеры от третьего лица.
  • Actor is a player that is capable of providing physical interaction with scenery. It has a rigid physical body, which is approximated with a capsule shape. It is a ready-to-use simple solution for a first-person character similar to Unity Character Controller. Actor - это игрок, способный обеспечить физическое взаимодействие с декорациями. Он имеет твердое физическое тело, которое приближается к форме капсулы. Это готовое к использованию простое решение для персонажа от первого лица, похожего на Unity Character Controller.

Only one player can be rendered into the viewport at a moment. To switch between cameras in the Editor Viewport of the UnigineEditor, use the Camera panel:Одновременно во вьюпорте может отображаться только один игрок. Для переключения между камерами в окне просмотра редактора UnigineEditor используйте панель Camera:

By checking the Main Player flag of a player you set the default player, which will be rendered when the scene is loaded in the Play mode.Установив флажок Main Player игрока, вы устанавливаете проигрыватель по умолчанию, который будет отображаться при загрузке сцены в режиме Play.

Project SettingsНастройки проекта#

Overall project settings adjustment in Unity Editor is usually done via the Project Settings window (menu: Edit > Project Settings). The Audio, Graphics, Physics, Quality levels and other settings affect the whole project.Общие настройки проекта в редакторе Unity обычно выполняются в окне Настройки проекта (меню: Edit > Project Settings). Настройки звука, графики, физики, качества и другие параметры влияют на весь проект.

In UNIGINE, the Common Settings and Preferences are available via Windows -> Settings menu at the Runtime section. The World settings are set for each world separately.В UNIGINE общие настройки и предпочтения доступны через меню Windows -> Settings в разделе Время выполнения . Настройки World устанавливаются для каждого мира отдельно.

Shader CompilationКомпиляция шейдеров#

In Unity Editor, Asynchronous Shader compilation is toggled on and off in the Editor settings (menu: Edit > Project Settings > Editor > Shader Compilation).В редакторе Unity Asynchronous Shader compilation включается и выключается в настройках редактора (меню: Edit > Project Settings > Editor > Shader Compilation).

In UNIGINE, a similar editor feature, Forced Shader Compilation, is available via both the toolbar and the Editor section of the Settings window.В UNIGINE аналогичная функция редактора, Forced Shader Compilation, доступна как через панель инструментов, так и через раздел Editor окна Settings.

PresetsПресеты#

You use Presets in Unity Editor when you need to reuse property settings that have bearing to different tasks, be it component settings, import settings or especially Project Settings. You can save the settings preset for a certain section of the Project Settings as a .preset asset and reuse in development later.Вы используете пресеты в редакторе Unity, когда вам нужно повторно использовать настройки свойств, которые имеют отношение к различным задачам, будь то настройки компонентов, настройки импорта или особенно Настройки проекта . Вы можете сохранить предустановку настроек для определенного раздела настроек проекта как ассет .preset и повторно использовать в разработке позже.

Presets are an Editor-only feature in Unity software.Предустановки доступны только для редактора в программном обеспечении Unity.

In UNIGINE, you can save and load presets for general physics, sound and render settings. The presets are stored as assets with the *.physics, *.sound and *.render extensions respectively. Use Load and Save .* asset buttons of the Settings window to work with presets of the corresponding settings section.В UNIGINE вы можете сохранять и загружать пресеты для общих настроек физики, звука и рендеринга. Пресеты хранятся как ассеты с расширениями *.physics, *.sound и *.render соответственно. Для работы с пресетами соответствующего раздела настроек используйте кнопки Load и Save .* asset окна Settings.

Saved assets appear in the Asset Browser. You can load the render settings by double-clicking the required .render asset.Сохраненные ассеты появятся в браузере ассетов. Вы можете загрузить настройки рендеринга, дважды щелкнув необходимый ассет .render.

Примечание
By default, a UNIGINE project provides settings for low, medium, high, ultra and virtual reality quality presets stored in the data/template_render_settings folder.По умолчанию проект UNIGINE предоставляет настройки для предустановок качества low, medium, high, ultra и virtual reality, хранящиеся в папке data/template_render_settings.

Presets are not an Editor-only feature in UNIGINE. You can use Physics, Sound and Render classes to manage presets for corresponding settings, for example, to switch between quality levels at run time.Предустановки не доступны только для редактора в UNIGINE. Вы можете использовать классы Physics, Sound и Render для управления предустановками для соответствующих настроек, например, для переключения между уровнями качества во время выполнения.

GraphicsГрафика#

In Unity Editor, settings for graphics quality are mostly gathered in the following sections:В редакторе Unity настройки качества графики в основном собраны в следующих разделах:

  • The Graphics section contains global settings for graphics. The Tier Settings provide platform-specific adjustments to rendering and shader compilation. One of the three Tier levels to be applied is defined automatically based on the platform used. Раздел Graphics содержит глобальные настройки графики. Tier Settings обеспечивает специфичные для платформы настройки рендеринга и компиляции шейдеров. Один из трех применяемых уровней Tier определяется автоматически в зависимости от используемой платформы.
  • The Quality section handles levels of graphical quality defined for each platform. Раздел Quality обрабатывает уровни качества графики, определенные для каждой платформы.

In UNIGINE, the rendering settings of the world can be found in the Render section of the Settings window. You can also toggle on and off the most common render features by using the Rendering menu:В UNIGINE настройки рендеринга мира можно найти в разделе Render окна Settings. Вы также можете включать и выключать наиболее распространенные функции рендеринга с помощью меню Rendering:

There is no platform-dependent quiality adjustments in UNIGINE, you should write your own logic to control the quality levels. You can use Render Presets for this purpose.В UNIGINE нет настроек качества, зависящих от платформы, вы должны написать свою собственную логику для контроля уровня качества. Для этой цели вы можете использовать Presets Render Presets .

Let's consider the most commonly used rendering settings in Unity software and their corresponding analogs in UNIGINE:Рассмотрим наиболее часто используемые настройки рендеринга в программе Unity и их соответствующие аналоги в UNIGINE:

Unity software UNIGINE
HDR Mode Render -> Buffers -> Color 16F
Rendering Path see below
Shaders Preloading Render -> Streaming -> Preload at World Loading
Pixel Light Count Forward Per-Object Limits
Texture Quality Render -> Textures -> Quality
Anisotropic Textures Render -> Textures -> Anisotropy
Anti Aliasing Render -> Antialiasing -> Supersampling
Soft Particles particles_base -> Soft Interaction
Realtime Reflection Probes Menu: Rendering -> Dynamic Reflections -> Enabled
Texture Streaming Render -> Streaming Settings
Shadows Render -> Shadows Settings
Shadow Cascades set per each World Light source
VSync Count Runtime -> Video settings

Rendering PathsПути рендеринга#

Unity software provides two non-legacy lighting and shading workflows: Deferred and Forward Rendering Paths defining the shading fidelity, as well as the rendering consumption and required hardware. You can choose the rendering path that your Project uses in the Graphics window, and you can override that path for each Camera.Программное обеспечение Unity предоставляет два не унаследованных рабочих процесса освещения и затенения: Deferred и Forward Пути рендеринга , определяющие точность затенения, а также потребление рендеринга и необходимое оборудование. Вы можете выбрать путь рендеринга , который ваш проект использует в окне Graphics, и вы можете переопределить этот путь для каждой камеры .

UNIGINE has the fixed Rendering Sequence represented by a combination of a full deferred renderer with forward rendering techniques:UNIGINE имеет фиксированную последовательность рендеринга , представленную комбинацией полного отложенного рендерера с методами прямого рендеринга:

  • All opaque (non-transparent) geometry is rendered in the deferred pass.Вся непрозрачная (непрозрачная) геометрия визуализируется в отложенном проходе.
  • Transparent geometry is rendered in the forward pass. Прозрачная геометрия отображается в прямом проходе.

You can reduce computational load by skipping certain rendering stages. Watch the dedicated video tutorial on using the Microprofile tool to optimize rendering:Вы можете снизить вычислительную нагрузку, пропустив определенные этапы рендеринга. Посмотрите специальный видеоурок по использованию инструмента Microprofile для оптимизации рендеринга:

Post-ProcessingПостобработка#

In Unity software, availability of post-processing effects is determined by the render pipeline used. In UNIGINE, similar effects are not a part of Post-processing but are integrated into the Rendering Sequence. Thus, Unity High Definition Render Pipeline (HDRP) is much closer to the rendering workflow in UNIGINE, than other render pipelines.В программном обеспечении Unity доступность эффектов постобработки определяется используемым конвейером рендеринга . В UNIGINE подобные эффекты не являются частью постобработки, а интегрированы в последовательность рендеринга . Таким образом, Unity High Definition Render Pipeline (HDRP) намного ближе к рабочему процессу рендеринга в UNIGINE, чем другие конвейеры рендеринга.

In Unity software the Volume framework is used to define the volumes where post-processing parameters and effects are locally (or globally) overridden. In UNIGINE you will have to write your own logic to smoothly interpolate between settings at different spaces (if such a requirement appears).В программном обеспечении Unity структура Volume используется для определения томов, в которых параметры и эффекты постобработки переопределяются локально (или глобально). В UNIGINE вам придется написать свою собственную логику для плавной интерполяции между настройками в разных местах (если такое требование появляется).

Примечание
UNIGINE offers a number of materials to create image postprocessing effects out of the box. They can be applied both globally and per camera.UNIGINE предлагает ряд материалов для создания эффектов постобработки изображений прямо из коробки. Их можно применять как глобально, так и для каждой камеры.

This section lists all common Unity post-processing techniques that can be achieved in UNIGINE as well regardless of render pipeline.В этом разделе перечислены все распространенные методы постобработки Unity, которые могут быть реализованы в UNIGINE, независимо от конвейера рендеринга.

Post-Processing EffectsЭффекты постобработки#
Unity software UNIGINE
Anti-aliasing methods:
  • FXAA
  • TAA
  • SMAA
  • MSAA
Anti-aliasing methods:
Ambient Occlusion Screen-Space Ambient Occlusion
Auto Exposure Camera Effects:
White Balance
Tonemapping
Bloom
Color Grading:
  • Tone
  • Lookup Texture
Chromatic Aberration Postprocess Materials:
  • post_color_correction
Grain
Deferred Fog Haze
Depth of Field Depth of Field
Motion Blur Motion Blur
Screen Space Reflection SSR
Contact Shadows Screen Space Shadows
Micro Shadows Cavity of SSAO

What's Next?Что дальше?#

Where to go from here? Куда идти дальше?

Make sure you don't miss the subtopics of this guide:Не забудьте прочитать другие темы этого руководства:

Thank you for reading the guide! You can proceed to the following sections for further learning:Спасибо, что прочитали руководство! Вы можете перейти к следующим разделам для дальнейшего изучения:

Последнее обновление: 12.11.2020