This page has been translated automatically.
Видеоуроки
Интерфейс
Основы
Продвинутый уровень
Подсказки и советы
Основы
Программирование на C#
Рендеринг
Профессиональный уровень (SIM)
Принципы работы
Свойства (properties)
Компонентная Система
Рендер
Физика
Редактор UnigineEditor
Обзор интерфейса
Контроль версий
Настройки и предпочтения
Работа с проектами
Настройка параметров ноды
Setting Up Materials
Настройка свойств
Освещение
Sandworm
Использование инструментов редактора для конкретных задач
Расширение функционала редактора
Встроенные объекты
Ноды (Nodes)
Объекты (Objects)
Эффекты
Декали
Источники света
Geodetics
World-ноды
Звуковые объекты
Объекты поиска пути
Player-ноды
Программирование
Основы
Настройка среды разработки
Примеры использования
C++
C#
UnigineScript
UUSL (Unified UNIGINE Shader Language)
Плагины
Форматы файлов
Материалы и шейдеры
Rebuilding the Engine Tools
Интерфейс пользователя (GUI)
VR Development
Двойная точность координат
API
Animations-Related Classes
Containers
Common Functionality
Controls-Related Classes
Engine-Related Classes
Filesystem Functionality
GUI-Related Classes
Math Functionality
Node-Related Classes
Objects-Related Classes
Networking Functionality
Pathfinding-Related Classes
Physics-Related Classes
Plugins-Related Classes
IG Plugin
CIGIConnector Plugin
Rendering-Related Classes
VR-Related Classes
Работа с контентом
Оптимизация контента
Материалы
Визуальный редактор материалов
Material Nodes Library
Miscellaneous
Input
Math
Matrix
Textures
Art Samples
Учебные материалы

Экспорт 3D-моделей из Maxon Cinema 4D

This article describes how to export your 3D Model From Maxon Cinema 4D so that it would have proper scaling, position, and orientation when imported to UnigineEditor.В этой статье описывается, как экспортировать вашу 3D-модель из Maxon Cinema 4D, чтобы она имела правильное масштабирование, положение и ориентацию при импорте в UnigineEditor.

See AlsoСмотрите также#

Pre-Export ArrangementПеред экспортом#

Before the export, do the following:Перед экспортом сделайте следующее:

  • Select Edit -> Preferences... and check that Centimeters are set as Unit Display.Выберите Edit -> Preferences... и убедитесь, что сантиметры установлены в качестве единиц отображения.

    In the Project Settings, check that Centimeters are set as working units.В Project Settings убедитесь, что в качестве рабочих единиц выбраны сантиметры.

    In the Viewport options (Options -> Configure), Background tab, set the grid cell size of 1 meter for convenience.В параметрах окна просмотра (Options -> Configure), вкладка Background, для удобства установите размер ячейки сетки равным 1 метру.

  • Orient the model towards the negative direction of the Z axis.Сориентируйте модель в отрицательном направлении оси Z.

  • Set the actual model size.Установите фактический размер модели.
  • Freeze all transformations to avoid placement issues.Заморозьте все трансформации, чтобы избежать проблем с размещением.

  • Check that materials are ready for export.Убедитесь, что материалы готовы к экспорту.

Export SettingsНастройки экспорта#

As soon as your model is ready for export, click File -> Export... -> FBX.Как только ваша модель будет готова к экспорту, щелкните File -> Export... -> FBX.

In the Export Settings window, enable Normals and Triangulate Geometry.В окне «Параметры экспорта» включите Normals и Triangulate Geometry.

Последнее обновление: 01.05.2021
Build: ()