This page has been translated automatically.
Видеоуроки
Интерфейс
Основы
Продвинутый уровень
Подсказки и советы
Основы
Программирование на C#
Рендеринг
Профессиональный уровень (SIM)
Принципы работы
Свойства (properties)
Компонентная Система
Рендер
Физика
Редактор UnigineEditor
Обзор интерфейса
Контроль версий
Настройки и предпочтения
Работа с проектами
Настройка параметров ноды
Setting Up Materials
Настройка свойств
Освещение
Sandworm
Использование инструментов редактора для конкретных задач
Расширение функционала редактора
Встроенные объекты
Ноды (Nodes)
Объекты (Objects)
Эффекты
Декали
Источники света
Geodetics
World-ноды
Звуковые объекты
Объекты поиска пути
Player-ноды
Программирование
Основы
Настройка среды разработки
Примеры использования
C++
C#
UnigineScript
UUSL (Unified UNIGINE Shader Language)
Плагины
Форматы файлов
Материалы и шейдеры
Rebuilding the Engine Tools
Интерфейс пользователя (GUI)
VR Development
Двойная точность координат
API
Animations-Related Classes
Containers
Common Functionality
Controls-Related Classes
Engine-Related Classes
Filesystem Functionality
GUI-Related Classes
Math Functionality
Node-Related Classes
Objects-Related Classes
Networking Functionality
Pathfinding-Related Classes
Physics-Related Classes
Plugins-Related Classes
IG Plugin
CIGIConnector Plugin
Rendering-Related Classes
VR-Related Classes
Работа с контентом
Оптимизация контента
Материалы
Визуальный редактор материалов
Material Nodes Library
Miscellaneous
Input
Math
Matrix
Textures
Art Samples
Учебные материалы

Экспорт 3D-моделей из Blender

This article describes how to export your 3D Model From Blender so that it would have proper scaling, position, and orientation when imported to UnigineEditor.В этой статье описывается, как экспортировать вашу 3D-модель из Blender, чтобы она имела правильное масштабирование, положение и ориентацию при импорте в UnigineEditor.

See AlsoСмотрите также#

Pre-Export ArrangementПеред экспортом#

Before the export, do the following:Перед экспортом сделайте следующее:

  • Check that Meters are set as working units.Убедитесь, что в качестве рабочих единиц выбраны метры.

    Blender scale should be: 1 unit = 1 meter.Масштаб Blender должен быть: 1 unit = 1 meter.

    For convenience, you can set the grid cell size equal to 1 meter:Для удобства можно установить размер ячейки сетки равным 1 метру:

  • Orient the model towards the negative direction of the Y axis, which is the front direction in Blender.Сориентируйте модель в отрицательном направлении оси Y, которое является направлением "вперед" в Blender.

  • Set the actual model size.Установите фактический размер модели.
  • Apply all transforms (Object -> Apply -> All Transforms).Примените все преобразования (Object -> Apply -> All Transforms).

    After applying all transforms, a part of model can be misplaced due to complex parenting. In this case, first clear parent (Object -> Parent -> Clear and Keep Transform), then apply transforms, and finally restore parent, if necessary.После применения всех преобразований часть модели может быть потеряна из-за сложных родительско-дочерних связей. В этом случае сначала очистите родительский элемент (Object -> Parent -> Clear and Keep Transform), затем примените преобразования и после этого восстановите родительский элемент, если необходимо.

  • Check that materials are ready for export.Убедитесь, что материалы готовы к экспорту.

Export SettingsНастройки экспорта#

As soon as your model is ready for export, click File -> Export -> FBX. Check that the parameters set in the Transform section are as follows:Как только ваша модель будет готова к экспорту, щелкните File -> Export -> FBX. Убедитесь, что параметры, установленные в разделе Transform, следующие:

Последнее обновление: 01.05.2021
Build: ()