This page has been translated automatically.
Видеоуроки
Interface
Essentials
Advanced
Подсказки и советы
Основы
Программирование на C#
Рендеринг
Принципы работы
Свойства (properties)
Компонентная Система
Рендер
Физика
Редактор UnigineEditor
Обзор интерфейса
Настройки и предпочтения
Работа с проектами
Настройка параметров ноды
Setting Up Materials
Настройка свойств
Освещение
Landscape Tool
Sandworm
Использование инструментов редактора для конкретных задач
Extending Editor Functionality
Встроенные объекты
Ноды (Nodes)
Объекты (Objects)
Эффекты
Декали
Источники света
Geodetics
World Nodes
Звуковые объекты
Объекты поиска пути
Players
Программирование
Основы
Настройка среды разработки
Примеры использования
C++
C#
UnigineScript
Унифицированный язык шейдеров UUSL
Плагины
File Formats
Rebuilding the Engine Tools
GUI
Двойная точность координат
API
Containers
Common Functionality
Controls-Related Classes
Engine-Related Classes
Filesystem Functionality
GUI-Related Classes
Math Functionality
Node-Related Classes
Objects-Related Classes
Networking Functionality
Pathfinding-Related Classes
Physics-Related Classes
Plugins-Related Classes
IG Plugin
CIGIConnector Plugin
Rendering-Related Classes
Работа с контентом
Оптимизация контента
Материалы
Material Nodes Library
Art Samples
Tutorials

Экспорт 3D-моделей из Autodesk 3ds Max

This article describes how to export your 3D Model from Autodesk 3ds Max so that it would have proper scaling, position, and orientation when imported to UnigineEditor.В этой статье описывается, как экспортировать вашу 3D-модель из Autodesk 3ds Max, чтобы она имела правильное масштабирование, положение и ориентацию при импорте в UnigineEditor.

See AlsoСмотрите также#

Pre-Export ArrangementПеред экспортом#

Before the export, do the following:Перед экспортом сделайте следующее:

  • Select Customize -> Units Setup and check that Centimeters are set as System Units.Выберите Customize -> Units Setup и убедитесь, что в качестве системных единиц выбраны сантиметры.

    For convenience, you can set the grid cell size equal to 1 meter:Для удобства можно установить размер ячейки сетки равным 1 метру:

    Go to Tools -> Grids and Snaps -> Grid and Snap Settings -> Home Grid.Перейдите к Tools -> Grids and Snaps -> Grid and Snap Settings -> Home Grid.

  • Orient the model towards the negative direction of the Y axis, which is the front direction in Autodesk 3ds Max.Сориентируйте модель в отрицательном направлении оси Y, которое является направлением "вперед" в Autodesk 3ds Max.

  • Set the actual model size.Установите фактический размер модели.
  • Reset all transforms (Utilities -> Reset XForm).Сбросьте все трансформации (Utilities -> Reset XForm).

  • Check that materials are ready for export.Убедитесь, что материалы готовы к экспорту.

Export SettingsНастройки экспорта#

As soon as your model is ready for export, click File -> Export. Save as type: Autodesk (*.FBX), click Save.Как только ваша модель будет готова к экспорту, щелкните File -> Export. Сохранить как тип: Autodesk (*.FBX), щелкните Save.

In FBX Export window, select Geometry and enable Smoothing Groups and Triangulate.В окне FBX Export выберите Geometry и включите Smoothing Groups и Triangulate.

In the Advanced Options, enable Automatic scale factor and select Z-up as the Up Axis.В Advanced Options включите масштабный коэффициент Automatic и выберите Z-up в качестве Up Axis.

Последнее обновление: 01.05.2021
Build: ()