Видеоуроки
Interface
Essentials
Advanced
Полезные советы
Принципы работы
Свойства (properties)
Компонентная Система
Рендер
Физика
Редактор UnigineEditor
Обзор интерфейса
Работа с ассетами
Настройки и предпочтения
Работа с проектами
Настройка параметров узла
Setting Up Materials
Setting Up Properties
Освещение
Landscape Tool
Sandworm (Experimental)
Использование инструментов редактора для конкретных задач
Extending Editor Functionality
Встроенные объекты
Nodes
Objects
Effects
Decals
Light Sources
Geodetics
World Objects
Sound Objects
Pathfinding Objects
Players
Программирование
Основы
Настройка среды разработки
Примеры использования
UnigineScript
C++
C#
Унифицированный язык шейдеров UUSL
File Formats
Rebuilding the Engine Tools
GUI
Двойная точность координат
API
Containers
Common Functionality
Controls-Related Classes
Engine-Related Classes
Filesystem Functionality
GUI-Related Classes
Math Functionality
Node-Related Classes
Objects-Related Classes
Networking Functionality
Pathfinding-Related Classes
Physics-Related Classes
Plugins-Related Classes
IG Plugin
CIGIConnector Plugin
Rendering-Related Classes
Работа с контентом
Оптимизация контента
Материалы
Art Samples
Tutorials

VFX Add-On

The VFX add-on provides a set of ready-to-use assets for the following special effects: Дополнение VFX предоставляет набор готовых к использованию ресурсов для следующих специальных эффектов:

  • Fire Огонь
  • Explosions Взрывы
  • Artillery shots Артиллерийские выстрелы
  • Rain drops Капли дождя
  • Snowflakes Снежинки
  • Water splashes Водяные брызги
  • Welding Сварка

Opening the WorldОткрытие мира#

To open the world containing special effects: Чтобы открыть мир, содержащий спецэффекты:

  • Install the VFX add-on (available via UNIGINE SDK Browser in the Add-Ons section) and add it to your project (by clicking Other Actions -> Configure Project -> Add-ons in the Projects section of UNIGINE SDK Browser). Установите дополнение VFX (доступно через UNIGINE SDK Browser в разделе Add-Ons) и добавьте его в свой проект (щелкнув Other Actions -> Configure Project -> Add-ons в разделе Projects файла UNIGINE SDK Browser).
  • Click File -> Open World (Ctrl + O) or open the Asset Browser window, open the vfx folder and choose one of the prepared scenes. The scene will open.
    Щелкните File -> Open World (Ctrl + O) или откройте окно Asset Browser, откройте папку vfx и выберите одну из подготовленных сцен. Сцена откроется.
Примечание
Separate nodes will also be available as *.node files in the data/vfx/nodes directory. Отдельные узлы также будут доступны как файлы *.node в каталоге data/vfx/nodes.
Последнее обновление: 11.11.2020