UnigineEditor
界面概述
资产工作流程
项目开发
调整节点参数
Setting Up Materials
Setting Up Properties
照明
Landscape Tool
Sandworm (Experimental)
使用编辑器工具执行特定任务
Extending Editor Functionality
编程
基本原理
搭建开发环境
Usage Examples
UnigineScript
C++
C#
UUSL (Unified UNIGINE Shader Language)
File Formats
Rebuilding the Engine Tools
GUI
双精度坐标
应用程序接口
Containers
Common Functionality
Controls-Related Classes
Engine-Related Classes
Filesystem Functionality
GUI-Related Classes
Math Functionality
Node-Related Classes
Objects-Related Classes
Networking Functionality
Pathfinding-Related Classes
Physics-Related Classes
Plugins-Related Classes
IG Plugin
CIGIConnector Plugin
Rendering-Related Classes

设置和首选项

The Settings window provides quick access to general editor and run-time settings, including hotkeys and controls, general physics, sound, render and video settings.使用Settings窗口可以快速访问常规编辑器和运行时设置,包括热键和控件,常规物理,声音,渲染和视频设置。

To open the window, choose Window -> Settings in the main menu:要打开窗口,请在主菜单中选择Window -> Settings

The following window will open:将打开以下窗口:

Settings Window设置窗口

Saving and Loading Settings保存和加载设置#

Via the Settings window, you can save and load presets for general physics, sound and render settings. The presets are stored in files with the corresponding extensions: *.physics, *.sound, *.render.通过Settings窗口,您可以保存和加载常规物理,声音和渲染设置的预设。预设存储在具有相应扩展名的文件中:*.physics, *.sound, *.render

注意
If there is no world currently loaded you'll only be able to save a new preset via the Save As New button.如果当前没有载入任何世界,则只能通过Save As New按钮保存新的预设。

By using this capability, you can prepare settings presets with low, medium, high and ultra settings for different devices.使用此功能,可以为不同设备准备具有低,中,高和超设置的设置预设。

To save the preset to a file:保存预设到文件:

  1. Go to the section with the required setting (Physics, Sound, Render) and click Save (to save changes to the current preset file) or Save As New (to save settings to a new file) in the upper right corner of the window.

    转到具有所需设置(Physics, Sound, Render)的部分,然后在窗口右上角单击Save(将更改保存到当前预设文件)或Save As New(将设置保存到新文件)。

  2. In the file dialog window that opens, specify a folder and a name for the preset file and click OK.在打开的文件对话框窗口中,为预设文件指定文件夹和名称,然后单击OK

The file with the corresponding extension will be created in the target folder and will be available in the Asset Browser immediately.具有相应扩展名的文件将在目标文件夹中创建,并将立即在资产浏览器中提供。

To load the preset from a file and apply it:加载文件中的预设并应用它:

  1. Go to the section with the required setting (Physics, Sound, Render) and simply select the desired preset from the dropdown in the upper right corner of the window.

    转到具有所需设置(Physics, Sound, Render)的部分,只需从窗口右上角的下拉列表中选择所需的预设即可。

The settings from the corresponding file will be loaded and applied.相应文件中的设置将被加载并应用。

注意
You can load the render settings via the Asset Browser. Simply double-click the required .render file: the settings will be applied automatically.您可以通过资源浏览器加载渲染设置。只需双击所需的.render文件:设置将自动应用。

By default, a UNIGINE project provides settings for low, medium, high and ultra quality presets stored in the data/template_render_settings folder.默认情况下,UNIGINE项目为存储在low, medium, high and low, medium, highdata/template_render_settings folder.

To revert your changes made to the preset simply click Revert after making them.还原对预设所做的更改,只需在进行更改后单击Revert

The previously saved settings will be loaded from the corresponding file and applied.先前保存的设置将从相应文件中加载并应用。

For your convenience there is also a [From World] option enabling you to use render, sound, and physics settings stored in a *.world file, that is currently loaded. If you change any settings when this option is selected, you can only save your changes to a new preset asset which will be automatically selected and applied.为方便起见,还有一个[From World]选项,使您可以使用存储在当前已加载的*.world文件中的渲染,声音和物理设置。如果在选择此选项后更改任何设置,则只能将更改保存到新的预设资产中,该资产将被自动选择并应用。

本節中的文章

最新更新: 2020-10-10