This page has been translated automatically.
视频教程
界面
要领
高级
实用建议
UnigineEditor
界面概述
设置和首选项
项目开发
调整节点参数
Setting Up Materials
Setting Up Properties
照明
Landscape Tool
Sandworm
使用编辑器工具执行特定任务
Extending Editor Functionality
嵌入式节点类型
Nodes
Objects
Effects
Decals
光源
Geodetics
World Nodes
Sound Objects
Pathfinding Objects
Players
编程
基本原理
搭建开发环境
Usage Examples
C++
C#
UnigineScript
UUSL (Unified UNIGINE Shader Language)
Plugins
File Formats
Rebuilding the Engine Tools
GUI
双精度坐标
应用程序接口
Containers
Common Functionality
Controls-Related Classes
Engine-Related Classes
Filesystem Functionality
GUI-Related Classes
Math Functionality
Node-Related Classes
Objects-Related Classes
Networking Functionality
Pathfinding-Related Classes
Physics-Related Classes
Plugins-Related Classes
IG Plugin
CIGIConnector Plugin
Rendering-Related Classes
创建内容
Content Optimization
Materials
Art Samples
Tutorials

从Autodesk Maya导出3D模型

This article describes how to export your 3D Model From Autodesk Maya so that it would have proper scaling, position, and orientation when imported to UnigineEditor.本文介绍如何从Autodesk Maya导出3D模型,以便在导入到UnigineEditor时具有正确的缩放比例,位置和方向。

See Also也可以看看#

Pre-Export Arrangement出口前安排#

Before the export, do the following:导出之前,请执行以下操作:

  • Check that World Coordinate System and Working Units are set as follows:检查是否按照以下方式设置了World Coordinate SystemWorking Units

    For convenience, you can set the grid cell size equal to 1 meter. Click Display -> Grid and set the following:为了方便起见,您可以将网格像元大小设置为等于1米。单击Display -> Grid并设置以下内容:

  • Orient the model towards the positive direction of the Z axis, which is the front direction in Autodesk Maya.将模型朝向Z轴的正方向(即Autodesk Maya中的正向)定向。

  • Set the actual model size.设置实际模型尺寸。
  • Freeze transformations (Modify -> Freeze Transformations), if needed.如果需要,冻结转换(Modify -> Freeze Transformations)。
  • Check that materials are ready for export.检查材料是否准备好出口。

Export Settings汇出设定#

As soon as your model is ready for export, click File -> Export All....一旦准备好导出模型,请单击File -> Export All...

Export settings should be the following:导出设置应为以下内容:

  • Files of type: FBX export
  • Units: Automatic
  • Up Axis: Y

最新更新: 2021-05-01
Build: ()