This page has been translated automatically.
视频教程
界面
要领
高级
实用建议
UnigineEditor
界面概述
设置和首选项
项目开发
调整节点参数
Setting Up Materials
Setting Up Properties
照明
Landscape Tool
Sandworm
使用编辑器工具执行特定任务
Extending Editor Functionality
嵌入式节点类型
Nodes
Objects
Effects
Decals
光源
Geodetics
World Nodes
Sound Objects
Pathfinding Objects
Players
编程
基本原理
搭建开发环境
Usage Examples
C++
C#
UnigineScript
UUSL (Unified UNIGINE Shader Language)
Plugins
File Formats
Rebuilding the Engine Tools
GUI
双精度坐标
应用程序接口
Containers
Common Functionality
Controls-Related Classes
Engine-Related Classes
Filesystem Functionality
GUI-Related Classes
Math Functionality
Node-Related Classes
Objects-Related Classes
Networking Functionality
Pathfinding-Related Classes
Physics-Related Classes
Plugins-Related Classes
IG Plugin
CIGIConnector Plugin
Rendering-Related Classes
创建内容
Content Optimization
Materials
Art Samples
Tutorials

从Blender导出3D模型

This article describes how to export your 3D Model From Blender so that it would have proper scaling, position, and orientation when imported to UnigineEditor.本文介绍如何从Blender导出3D模型,以便在导入到UnigineEditor时具有正确的缩放比例,位置和方向。

See Also也可以看看#

Pre-Export Arrangement出口前安排#

Before the export, do the following:导出之前,请执行以下操作:

  • Check that Meters are set as working units.检查仪表是否设置为工作单位。

    Blender scale should be: 1 unit = 1 meter.Blender标度应为:1 unit = 1 meter

    For convenience, you can set the grid cell size equal to 1 meter:为了方便起见,您可以将网格像元大小设置为等于1米:

  • Orient the model towards the negative direction of the Y axis, which is the front direction in Blender.将模型朝向Y轴的负方向(即Blender中的正向)定向。

  • Set the actual model size.设置实际模型尺寸。
  • Apply all transforms (Object -> Apply -> All Transforms).应用所有变换(Object -> Apply -> All Transforms)。

    After applying all transforms, a part of model can be misplaced due to complex parenting. In this case, first clear parent (Object -> Parent -> Clear and Keep Transform), then apply transforms, and finally restore parent, if necessary.应用所有转换后,由于复杂的育儿,模型的一部分可能会放错位置。在这种情况下,请先清除父代(Object -> Parent -> Clear and Keep Transform),然后应用转换,最后在必要时还原父代。

  • Check that materials are ready for export.检查材料是否准备好出口。

Export Settings汇出设定#

As soon as your model is ready for export, click File -> Export -> FBX. Check that the parameters set in the Transform section are as follows:一旦准备好导出模型,请单击File -> Export -> FBX。检查在Transform部分中设置的参数是否如下:

最新更新: 2021-05-01
Build: ()