This page has been translated automatically.
视频教程
界面
要领
高级
实用建议
UnigineEditor
界面概述
设置和首选项
项目开发
调整节点参数
Setting Up Materials
Setting Up Properties
照明
Landscape Tool
Sandworm
使用编辑器工具执行特定任务
Extending Editor Functionality
嵌入式节点类型
Nodes
Objects
Effects
Decals
光源
Geodetics
World Nodes
Sound Objects
Pathfinding Objects
Players
编程
基本原理
搭建开发环境
Usage Examples
UnigineScript
C++
C#
UUSL (Unified UNIGINE Shader Language)
File Formats
Rebuilding the Engine Tools
GUI
双精度坐标
应用程序接口
Containers
Common Functionality
Controls-Related Classes
Engine-Related Classes
Filesystem Functionality
GUI-Related Classes
Math Functionality
Node-Related Classes
Objects-Related Classes
Networking Functionality
Pathfinding-Related Classes
Physics-Related Classes
Plugins-Related Classes
IG Plugin
CIGIConnector Plugin
Rendering-Related Classes
创建内容
Content Optimization
Materials
Art Samples
Tutorials

从Autodesk 3ds Max导出3D模型

This article describes how to export your 3D Model from Autodesk 3ds Max so that it would have proper scaling, position, and orientation when imported to UnigineEditor.本文介绍如何从Autodesk 3ds Max导出3D模型,以便在导入到UnigineEditor时具有正确的缩放比例,位置和方向。

See Also也可以看看#

Pre-Export Arrangement出口前安排#

Before the export, do the following:导出之前,请执行以下操作:

  • Select Customize -> Units Setup and check that Centimeters are set as System Units.选择Customize -> Units Setup并检查“厘米”是否设置为“系统单位”。

    For convenience, you can set the grid cell size equal to 1 meter:为了方便起见,您可以将网格像元大小设置为等于1米:

    Go to Tools -> Grids and Snaps -> Grid and Snap Settings -> Home Grid.转到Tools -> Grids and Snaps -> Grid and Snap Settings -> Home Grid

  • Orient the model towards the negative direction of the Y axis, which is the front direction in Autodesk 3ds Max.将模型朝向Y轴的负方向(即Autodesk 3ds Max中的正向)定向。

  • Set the actual model size.设置实际模型尺寸。
  • Reset all transforms (Utilities -> Reset XForm).重置所有变换(Utilities -> Reset XForm)。

  • Check that materials are ready for export.检查材料是否准备好出口。

Export Settings汇出设定#

As soon as your model is ready for export, click File -> Export. Save as type: Autodesk (*.FBX), click Save.一旦准备好导出模型,请单击File -> Export。另存为:Autodesk (*.FBX),单击Save

In FBX Export window, select Geometry and enable Smoothing Groups and Triangulate.FBX Export窗口中,选择Geometry并启用Smoothing GroupsTriangulate

In the Advanced Options, enable Automatic scale factor and select Z-up as the Up Axis.Advanced Options中,启用Automatic比例因子,然后选择Z-up作为Up Axis

最新更新: 2021-05-01
Build: ()