This page has been translated automatically.
视频教程
界面
要领
高级
实用建议
UnigineEditor
界面概述
设置和首选项
项目开发
调整节点参数
Setting Up Materials
Setting Up Properties
照明
Landscape Tool
Sandworm
使用编辑器工具执行特定任务
Extending Editor Functionality
嵌入式节点类型
Nodes
Objects
Effects
Decals
光源
Geodetics
World Nodes
Sound Objects
Pathfinding Objects
Players
编程
基本原理
搭建开发环境
Usage Examples
C++
C#
UnigineScript
UUSL (Unified UNIGINE Shader Language)
Plugins
File Formats
Rebuilding the Engine Tools
GUI
双精度坐标
应用程序接口
Containers
Common Functionality
Controls-Related Classes
Engine-Related Classes
Filesystem Functionality
GUI-Related Classes
Math Functionality
Node-Related Classes
Objects-Related Classes
Networking Functionality
Pathfinding-Related Classes
Physics-Related Classes
Plugins-Related Classes
IG Plugin
CIGIConnector Plugin
Rendering-Related Classes
创建内容
Content Optimization
Materials
Art Samples
Tutorials

从Maxon Cinema 4D导出3D模型

This article describes how to export your 3D Model From Maxon Cinema 4D so that it would have proper scaling, position, and orientation when imported to UnigineEditor.本文介绍如何从Maxon Cinema 4D导出3D模型,以便在导入到UnigineEditor时具有正确的缩放比例,位置和方向。

See Also也可以看看#

Pre-Export Arrangement出口前安排#

Before the export, do the following:导出之前,请执行以下操作:

  • Select Edit -> Preferences... and check that Centimeters are set as Unit Display.选择Edit -> Preferences...并检查“厘米”是否设置为“单位显示”。

    In the Project Settings, check that Centimeters are set as working units.Project Settings中,检查是否已将厘米设置为工作单位。

    In the Viewport options (Options -> Configure), Background tab, set the grid cell size of 1 meter for convenience.在“视口”选项(Options -> Configure)的“ Background”选项卡中,为方便起见,将栅格像元大小设置为1米。

  • Orient the model towards the negative direction of the Z axis.将模型朝向Z轴的负方向。

  • Set the actual model size.设置实际模型尺寸。
  • Freeze all transformations to avoid placement issues.冻结所有转换以避免放置问题。

  • Check that materials are ready for export.检查材料是否准备好出口。

Export Settings汇出设定#

As soon as your model is ready for export, click File -> Export... -> FBX.一旦准备好导出模型,请单击File -> Export... -> FBX

In the Export Settings window, enable Normals and Triangulate Geometry.在“导出设置”窗口中,启用NormalsTriangulate Geometry

最新更新: 2021-05-01
Build: ()