视频教程
界面
要领
高级
实用建议
UnigineEditor
界面概述
资产工作流程
设置和首选项
项目开发
调整节点参数
Setting Up Materials
Setting Up Properties
照明
Landscape Tool
Sandworm
使用编辑器工具执行特定任务
Extending Editor Functionality
嵌入式节点类型
Nodes
Objects
Effects
Decals
Light Sources
Geodetics
World Objects
Sound Objects
Pathfinding Objects
Players
编程
基本原理
搭建开发环境
Usage Examples
UnigineScript
C++
C#
UUSL (Unified UNIGINE Shader Language)
File Formats
Rebuilding the Engine Tools
GUI
双精度坐标
应用程序接口
Containers
Common Functionality
Controls-Related Classes
Engine-Related Classes
Filesystem Functionality
GUI-Related Classes
Math Functionality
Node-Related Classes
Objects-Related Classes
Networking Functionality
Pathfinding-Related Classes
Physics-Related Classes
Plugins-Related Classes
IG Plugin
CIGIConnector Plugin
Rendering-Related Classes

Road Tool Constructor Add-On

The Road Tool Constructor add-on contains a set of ready-to-use assets that can be used as construction elements for roads creation. They can be assigned to points and segments of the WorldSplineGraph tool. Road Tool Constructor附加组件包含一组可立即使用的资产,可用作道路创建的构造元素。可以将它们分配给 WorldSplineGraph 工具的点和线段。

  • Two road segments两个路段
  • Crossroads junction十字路口路口
  • Roundabout junction回旋处交汇处
  • Y-junction Y型结
  • T-junction T型结

Opening the World开放世界#

To open the world containing models:打开包含模型的世界:

  • Install the Road Tool Constructor add-on (available via UNIGINE SDK Browser in the Add-Ons section) and add it to your project (by clicking Other Actions -> Configure Project -> Add-ons in the Projects section of UNIGINE SDK Browser).安装Road Tool Constructor附加组件(可通过Add-Ons部分中的UNIGINE SDK Browser获得)并将其添加到 您的项目(在 UNIGINE SDK的Add-Ons部分中单击Other Actions -> Configure Project -> Add-ons 浏览器)。
  • Click File -> Open World (Ctrl + O) or open the Asset Browser window, open the data folder, and select the road_tool_constructor world. The scene will open.
    单击File -> Open WorldCtrl + O)或打开Asset Browser窗口,打开data文件夹,然后选择road_tool_constructor世界。场景将打开。
注意
Node references for each element, as well as all necessary FBX models, textures, and materials are available in the data/constructor/ directory.每个元素的节点引用以及所有必需的FBX模型,纹理和材质在data/constructor/目录中可用。
最新更新: 2020-11-11