This page has been translated automatically.
Видеоуроки
Интерфейс
Основы
Продвинутый уровень
Подсказки и советы
Основы
Программирование на C#
Рендеринг
Профессиональный уровень (SIM)
Принципы работы
Свойства (properties)
Компонентная Система
Рендер
Физика
Редактор UnigineEditor
Обзор интерфейса
Контроль версий
Настройки и предпочтения
Работа с проектами
Настройка параметров ноды
Setting Up Materials
Настройка свойств
Освещение
Sandworm
Использование инструментов редактора для конкретных задач
Расширение функционала редактора
Встроенные объекты
Ноды (Nodes)
Объекты (Objects)
Эффекты
Декали
Источники света
Geodetics
World-ноды
Звуковые объекты
Объекты поиска пути
Player-ноды
Программирование
Основы
Настройка среды разработки
Примеры использования
C++
C#
UnigineScript
UUSL (Unified UNIGINE Shader Language)
Плагины
Форматы файлов
Материалы и шейдеры
Rebuilding the Engine Tools
Интерфейс пользователя (GUI)
VR Development
Двойная точность координат
API
Animations-Related Classes
Containers
Common Functionality
Controls-Related Classes
Engine-Related Classes
Filesystem Functionality
GUI-Related Classes
Math Functionality
Node-Related Classes
Objects-Related Classes
Networking Functionality
Pathfinding-Related Classes
Physics-Related Classes
Plugins-Related Classes
IG Plugin
CIGIConnector Plugin
Rendering-Related Classes
VR-Related Classes
Работа с контентом
Оптимизация контента
Материалы
Визуальный редактор материалов
Сэмплы материалов
Material Nodes Library
Miscellaneous
Input
Math
Matrix
Textures
Art Samples
Учебные материалы

Экспорт 3D-моделей из Autodesk Maya

This article describes how to export your 3D Model From Autodesk Maya so that it would have proper scaling, position, and orientation when imported to UnigineEditor.В этой статье описывается, как экспортировать вашу 3D-модель из Autodesk Maya, чтобы она имела правильное масштабирование, положение и ориентацию при импорте в UnigineEditor.

See AlsoСмотрите также#

Pre-Export ArrangementПеред экспортом#

Before the export, do the following:Перед экспортом сделайте следующее:

  • Check that World Coordinate System and Working Units are set as follows:Убедитесь, что World Coordinate System и Working Units установлены следующим образом:

    For convenience, you can set the grid cell size equal to 1 meter. Click Display -> Grid and set the following:Для удобства можно установить размер ячейки сетки равным 1 метру. Щелкните Display -> Grid и установите следующее:

  • Orient the model towards the positive direction of the Z axis, which is the front direction in Autodesk Maya.Сориентируйте модель в положительном направлении оси Z, которое является направлением "вперед" в Autodesk Maya.

  • Set the actual model size.Установите фактический размер модели.
  • Freeze transformations (Modify -> Freeze Transformations), if needed.При необходимости зафиксируйте трансформации (Modify -> Freeze Transformations).
  • Check that materials are ready for export.Убедитесь, что материалы готовы к экспорту.

Export SettingsНастройки экспорта#

As soon as your model is ready for export, click File -> Export All....Как только ваша модель будет готова к экспорту, щелкните File -> Export All....

Export settings should be the following:Настройки экспорта должны быть следующими:

  • Files of type: FBX export
  • Units: Automatic
  • Up Axis: Y

Последнее обновление: 19.12.2023
Build: ()