Jump to content

[SOLVED] Crash when NavigationMesh present in a NodeReference

Go to solution Solved by simon.wade,

Recommended Posts

Hey hey! I seem to be encountering a crash whenever I place a NavigationMesh inside a reference node.

I'm using Unigine, running on Windows, and launching with Main_double_x64.exe.

Here's the deal:

  • If I load a world containing a single node - the NavigationMesh - then everything seems okay.
  • If I have a world containing a single reference node, and the referenced node is the same NavigationMesh as before, then the engine crashes while loading.

The exception is an access violation:


And the call stack looks like this:


I've attached a data folder that reproduces the issue for me: navigation_mesh_crash.zip. This is pretty hacked together, so apologies for any weirdness in there. Also, I haven't included core.ung for obvious size-related reasons. :D

It contains two worlds ("good" and "bad") representing the two use cases mentioned earlier.

Curiously, if I launch with the debug executable (Main_double_x64d.exe), then it seems to work just fine.

Thanks in advance for any help! And let me know if there's more detail that you need.

Link to comment

Minor Update: One of our graphics team just told me that they tried editing a NodeReference containing a NavigationMesh and it crashed the editor. They have since moved the NavigationMesh outside of the reference and that's resolved the issue for them. Sounds like the same problem.

Link to comment

Hi, Simon!

Yeah, we reproduced the issue. Indeed, the crash of editor and main app is caused by the same bug. It is already sent to the developers and fix will come in future update.

So far, we would recommend to avoid creating Node References from Navigation Mesh and Navigation Sector, if it won't cause too much inconveniences.

Thank you for reporting!

  • Like 1
Link to comment
  • 2 months later...
  • silent changed the title to [SOLVED] Crash when NavigationMesh present in a NodeReference
  • Create New...