Jump to content

[SOLVED] Can't open "mars.fbx/sphere.mesh" file in the final build executable


Recommended Posts

In Visual Studio,using c++, i use the mesh of a model (mars.fbx created in Blender) with the instructions:

   Unigine::ObjectMeshStaticPtr obj;

   Unigine::MeshPtr mesh;

    mesh = Unigine::Mesh::create();


    obj = Unigine::ObjectMeshStatic::create(mesh);
    obj->setPosition(Unigine::Math::Vec3(0, 0, 0));

When i run the executable in Visual Studio,ii's all ok.

But in the final build, there is the message Can't open "mars.fbx/sphere.mesh" file on the screen.

But the mesh file and the meta file are present in the .runtime folder in the final build.

I need help

Link to comment

Hello! Apparently the problem is that you didn't build the app for release. To do this, to the left of the Local Windows Debugger button, select the Release item in the drop-down list and press Ctrl+B. After that, try to build your application from the editor again. With best regards, from the UNIGINE team.

  image.png => image.png

Link to comment
  • silent changed the title to [SOLVED] Can't open "mars.fbx/sphere.mesh" file in the final build executable
  • Create New...