Jump to content

Missing Lights in VoxelProbes


Recommended Posts



I have a Problem with Lights and Voxel Probes.

I want to add a light inside a tunnel and bake it with a VoxelProbe so that I can hide it at large distances to safe performance. I recreated the Problem in an empty scene with all default settings. Now the Problem is that it seems like the VoxelProbes dont really interact with Projected lights. The Voxel spheres are very dark and without the light visible its very hard to see any light at all.

I tried a lot of different settings and nothings seems to work except bumping up the light intensity to a very high number and that makes the light itself way too bright.


- Scene with active lights and voxel probe (how it should look)



- Scene without light and only voxel probe (how it looks now, way too dark with barely any light)



- closeup of voxels at the wall near the light



I dont really know any solution and if I maybe forget something simple in the setting.

Help is greatly appriciated, thanks in advance!


Link to comment

Hello @tommate!

Within using Lightmaps or Voxel Probes you are allowed only to bake non-directional lights. Please see image attached, here is directed lights which is not baked to probes at all.

To get around this you may try to increase lights intensity a lot and bake probes again. Then revert lights to their original state and use them alongside with baked probes, but turn off lights sources by visibility distance.



Link to comment


Thanks for the reply!

I see, is this working as intended or is this a bug? Because I didnt find any mention regarding this limitation in the Documentation.

Link to comment
  • Create New...