Jump to content

photo

Recommended Posts

Hi Unigine team,
Please see the pictures, according to my system hardware specs, in SDK browser version 2.0.5, I have selected & applied DirectX 12 and Vulkan but still  run DirectX 11 in Unigine 2.16??!! why does not work!?  Is support my graphics card DirectX 12 & Vulkan API ??

11111111.jpg

4444444.jpg

 

 

222222.jpg

33333333.jpg

Edited by ahmad.karami
Link to comment

Good news is that your GPU definitely supports both DX12 and Vulkan.

Can you run the DirectX Diagnostic Tool for me, and let me know under DirectX Version what is says?

  • From Start, type dxdiag in the Search box, and then press enter.

  • Tap or click on dxdiag from the results.

  • Check DirectX Version on the first page of the report in the System Information section.

 

For Vulkan you need the Vulkan SDK, which I don't know if you installed it already or not.

In any case you can download the latest Vulkan SDK here.

Cheers

Edited by Ihde.Sascha
Link to comment

Hello!

@ahmad.karamiAt the moment as experimental feature both DirectX12 and Vulkan API is only supported for running through runtime application and not available for the Unigine Editor.

Thanks!

Link to comment
1 hour ago, Ihde.Sascha said:

Good news is that your GPU definitely supports both DX12 and Vulkan.

Can you run the DirectX Diagnostic Tool for me, and let me know under DirectX Version what is says?

  • From Start, type dxdiag in the Search box, and then press enter.

  • Tap or click on dxdiag from the results.

  • Check DirectX Version on the first page of the report in the System Information section.

 

For Vulkan you need the Vulkan SDK, which I don't know if you installed it already or not.

In any case you can download the latest Vulkan SDK here.

Cheers

Thank you @Ihde.Sascha I see DirectX 12 , but I don't understand , really my GPU is support DX 12 & Vulkan API or no ??

image.png.2cb2210b9326d2e611d1d6425169e384.png

Link to comment
6 minutes ago, bmyagkov said:

Hello!

@ahmad.karamiAt the moment as experimental feature both DirectX12 and Vulkan API is only supported through runtime application only and not available for running through Editor.

Thanks!

Thank you @bmyagkov

I see this GPU Error for running Samples in C++ & Unigine Script , Why does not work ?!? 

image.thumb.png.fa797b416b14719a829cc9aaac7b9faf.png

Link to comment
12 minutes ago, bmyagkov said:

Hello!

@ahmad.karamiAt the moment as experimental feature both DirectX12 and Vulkan API is only supported for running through runtime application and not available for the Unigine Editor.

Thanks!

 

Thank you @bmyagkov

I see this GPU Error for running Samples in "3rd Party" when I click on the buttons "RUN" , Why does not work ?!? 

Also For C#, when I click on the buttons Run, nothing happens! Not even a message is shown, nothing!

image.thumb.png.622a9b453873639940b6aa5be69a983a.png

image.thumb.png.f42a18bcbd5882ecb2b2d43c49f3aae3.png

Link to comment
1 hour ago, Ihde.Sascha said:

For Vulkan you need the Vulkan SDK, which I don't know if you installed it already or not.

In any case you can download the latest Vulkan SDK here.

@Ihde.Sascha

I must select all options for Vulkan? Or not all? which options I must select & download?

image.png.14d5fb78031b1d115cdd3c7a63e773f5.png

Link to comment

The issue with DX12 may be also related to that fact that you are running Windows 10 build from 2016 (1607). Try to update to the latest Windows 10 (21H2) and see how it goes. Also don't forget to download and install the latest available GPU driver.

GTX760 is old Kepler-based GPU so I wouldn't expect that it would fully support DX12 / Vulkan on hardware level. There were also reports that some DX12 games are not working on this kind of GPUs (for example, Death Stranding).

According to nVidia website, Vulkan 1.3 is not supported on Kepler (GTX7xx) GPUs:

Quote

NVIDIA provides full Vulkan 1.3 support and functionality on NVIDIA GeForce and Quadro graphics card with one of the following Ampere, Turing, Volta, Pascal and Maxwell (first and second generation) based GPUs:

So to my understanding you need to have at least some GTX9xx series GPU to use Vulkan and run UNIGINE 2.16 demos.

You can check your current device API level by downloading Vulkan Hardware Capability Viewer and checking apiVersion parameter:

image.png

Thanks!

How to submit a good bug report
---
FTP server for test scenes and user uploads:

Link to comment
×
×
  • Create New...