Jump to content

[SOLVED] CIGI view type can't find material


Recommended Posts


With a fresh 2.15.1 new IG project, when sending a CIGI view definition with view type set to a valid value defined in ig_config.xml, I always get a warning:

View::setViewType cant find material post_sensor_heat

But the post process material does exists, I can set it in the post process in the editor if needed. I could have sweared that this worked in the past, but even with a fresh new IG project it doesn't work. So what am I missing here?


Link to comment


this is our mistake, we forgot to change ig_template.xml from template

please change block <view_types> in your config

		<view_type type="1" post_materials="Unigine::post_sensor_heat"/>
		<view_type type="2" post_materials="Unigine::post_sensor_green"/>
		<view_type type="3" post_materials="Unigine::post_sensor_white"/>
		<view_type type="4" post_materials="Unigine::post_sensor_red"/>
		<view_type type="5" post_materials="Unigine::post_sensor_white,Unigine::post_sensor_heat"/>


Link to comment
  • silent changed the title to [SOLVED] CIGI view type can't find material
  • Create New...