Jump to content

Screen space shadows accuracy @far distances


photo

Recommended Posts

I want to use screen space shadows instead of sun shadows as they are way cheaper for our project.

We have long camera distances to the objects with shadow (top down, aerial views), and we have small objects (houses, cars..)

I need to maintain shadows, as without it does looks way too unrealistic.

as it is, I cannot find settings for our intended camera positions (screen composition) and the technical settings for achieving shadowing in a quality way.

I played around with different setups, but I am stuck. Basically I need ground shadows from an aerial view (around 1000m above ground) with a 90 mm focal lenght.

My desired picture would be more like 5000 height and a focal lenght of 400, to have a super flat scene, but at those height basically nothing works any more.

Is this somehow possible in 2.15 (I read about that zoom in Mars demo?),

best Werner

image.thumb.png.d0546da2bd2bbc4fd0208fc157b5ed23.png

Link to comment

Hi Werner,

I assume that you are adjusted screen-space shadows directly in the Light World object?

Increasing steps number and noise steps can give you slightly better results. Unfortunately, without seeing the actual test scene it's hard to suggest any other specific settings.

Thanks!

How to submit a good bug report
---
FTP server for test scenes and user uploads:

Link to comment

Hi.

yes, I adjusted every parameter.

What I am thinking of is, that the screenspace shadow seems to be dependent of the camera distance. So the actual distance of an object to the camera.

If I change the lenght of the lense to zoom in, the screen space shadows are not affected. Is this correct?

If it is so, is there a way to get around that? Maybe Iam thinking along the wrong paths... without knowing how screen space shadows work.

Basically I think it is a resolution issue, isnt it? So too small objects just drop out? Or a depth issue? Is there something we can change to get higher quality results? The Editors parameters dont help me.

Best. Werner

 

Link to comment

Are you not using default cascaded shadows from Light World object at all?

Screen space shadows as any other screen space effect is depends on the current frame buffers and their resolution. So if you have very distant small objects (that covers very small amount of pixels in the depth buffer) you will have bad times. In theory increasing resolution should help (for example, enabling supersampling).

You can also play with the shader itself and try to adjust it for your needs (data\core\materials\shaders\render\light\screen_space_shadow.h). Maybe that would be more efficient.

If you could prepare a minimal test scene (with just cubes planes) and set your camera settings as it would be in the final app - we can check what can be done in that specific scenario.

Thanks!

How to submit a good bug report
---
FTP server for test scenes and user uploads:

Link to comment

hey.

We have way too many dynamic objects for using cascade shadows from World Light. The performance drop is way too much. As well it is not really working for the same reasons, resolution, depth, size of objects. 

SSS do not impact performance, so I would be happy to use them. As well the perspective of the camera would support it (top down, angled, far away). Simply speaking, its more a 'Drop shadow' effect.

Let us look into the shaders, I will send a scene if we cannot progress. Thanks for the directions! Best. werner

Link to comment

If you do not need accurate shadows, you could try to use a simple shadow geometry for your cars. So disable shadows for your realistic surfaces and clear the viewport mask of the shadow geometry. This could at least help with performance when using shadow maps.

Another possibility would be adding fake shadows with decals. If you are that far away with your camera, a simple blob shadow might be enough.

Edited by devrom
  • Thanks 2
Link to comment
×
×
  • Create New...