Jump to content

Unable to Run Projects from UNIGINE SDK Browser


Recommended Posts

I installed UNIGINE When I try to Run a projects from the SDK Browser (by clicking the "Run" button), the console shows-up briefly and closes rapidly (within a second). The file "log.txt" terminates like that:

---- Application ----
Loading "dxgi.dll"...
Loading "openal32.dll"...
Set 860x560 fullwindow video mode

The only way I can Run a UNIGINE app is through the IDE (VisualStudio 2019) by doing <Ctrl-F5>.

What am I missing?

Link to comment


Could you please give us any step-by-step instructions how to reproduce this issue?

I think we would also need some additional information, like:

  • Do you have any non-latin characters in path?
  • What's your current OS name and version and hardware (CPU / GPU model + driver version)?
    • If you can attach dxdiag log it would be even better :)
  • .project file from the root directory of non-working project
  • SDK Browser logs from %USERPROFILE%\AppData\Local\UNIGINE_SDK_Browser

I've tried to create couple of projects and they are running just fine, no force-closing or whatsoever.


How to submit a good bug report
FTP server for test scenes and user uploads:

Link to comment

The project that I'm using is the sample "oil_refinery". But the same thing happen when I create a simple project from scratch using the procedure describe here: https://developer.unigine.com/en/docs/latest/code/uniginescript/application?rlang=cpp

My HW:

  • Alienware laptop
  • Operating System: Windows 10 Enterprise 64-bit (10.0, Build 19042) (19041.vb_release.191206-1406)
  • Processor: Intel(R) Core(TM) i9-10980HK CPU @ 2.40GHz (16 CPUs), ~3.1GHz
  • Memory: 32768MB RAM
  • DirectX Version: DirectX 12
  • NVIDIA GeForce RTX 3080 Laptop GPU (driver 496.76)

The HW doesn't seems to be the problem because the UNIGINE apps are running when launched from visual-studio. Once I load the "oil_refinery" in visual-studio (by clicking "Open code IDE" from the SDK Browser), I compile and run with <Ctrl-F5> or, from the menu Tools/Command Line/Developer Command Prompt, if I start the batch-file "...\Documents\UNIGINE Projects\oil_refinery\launch_release.bat" from there it also works.

The attach log file is the one from "C:\Users\dracicot\Documents\UNIGINE Projects\oil_refinery\bin\log.txt", generated while pressing "Run" from the "UNIGINE SDK Browser" under "My Projects" on the project-icon "oil_refinery".

log.txt browser2021-11-24_14-00-30.log

Link to comment


@dracicot, you mention that running straight from ".bat" file works fine, so I will try to guess that some of SDK Browser options overwrite startup settings. May I ask you to share screenshot with your setup?

This window is accessible by the button to the right of your avatar in the SDK browser:


Link to comment

If I run the batch-file from a cmd-prompt it doesn't work (it does the same thing as if I try to Run from the Browser. But if I start the batch-file from the visual-studio cmd-prompt, then it works fine (VisualStudio menu Tools/Command Line/Developer Command Prompt). Here's my Option Window:

The Storage Path: C:/Users/dracicot/Unigine SDK Browser/


Link to comment
  • Create New...