sample cross road


photo

Recommended Posts

I modified the shape and arranged it using the bone function of the sample crossroad.
(I changed the scale of the sample straight road, so there was a problem when using the cross road for Spline Graph. So I placed the model directly in the world.)

But when I rerun the editor, it comes back to its original form.
The deformed bone data remains exactly as I set it.

image.png.d4eac5b54c94d130e2dbfeaddc1bfe50.png

 

When I slightly edit the bone data offset or the bound node, it returns to the shape I worked on.

image.png.13c7f7ceeac64773cd95a8e6bc6cbece.png

 

 

And when I clone a cross road node, the bind node of the cloned node matches the child node of the original.

 

Please let me know what I'm using wrong.

 

Link to post

dongju.jeong

Cross roads sample is based on experimental WorldSplineGraph object that currently have a lot of bugs and may behave incorrectly. We aware of this and I'm afraid no proper fix would be released for this object.

We plan to simplify splines behavior in the future versions of SDK and make them to produce a simple meshes as a result (what to do with skinned mesh junctions we not decided yet).

  • Like 1

How to submit a good bug report
---
FTP server for test scenes and user uploads:

Link to post
8 hours ago, dongju.jeong said:

I modified the shape and arranged it using the bone function of the sample crossroad.
(I changed the scale of the sample straight road, so there was a problem when using the cross road for Spline Graph. So I placed the model directly in the world.)

But when I rerun the editor, it comes back to its original form.
The deformed bone data remains exactly as I set it.

image.png.d4eac5b54c94d130e2dbfeaddc1bfe50.png

 

When I slightly edit the bone data offset or the bound node, it returns to the shape I worked on.

image.png.13c7f7ceeac64773cd95a8e6bc6cbece.png

 

 

And when I clone a cross road node, the bind node of the cloned node matches the child node of the original.

 

Please let me know what I'm using wrong.

 

With current API is not big problem to make exporter, which exports whole graph into .mesh. It solves majority of problems. But there are still other issues, like wierd UV stretching, random rotation of road pieces along axis etc....So this tool is currently not usable for production. Only workaround I know about is make this export tool, export final shape into 3dsmax (or similar) and use this shape as template to model it properly there. Not productive at all, but at least doable.

Edited by demostenes
  • Thanks 1
Link to post