Undo action taking too much time


Recommended Posts


I'm currently using Unigine's old Editor version 2.6.1. And each time I perform an undo, the editor freezes for 1 or 2 seconds.

In the case of larger scenes, the editor may take up to 10 seconds on each undo.

I have reinstalled Unigine on another machine and the problem still occurs. I have noticed that it doesn't happen on older or newer versions of Unigine.

Is this normal? Is there anyway I can avoid this?

Thanks in advance.

Link to post


Karim, what happens if you create a new 2.6 project? Will undo also take a lot of time too? 

So far, the only thing I can advise you right now is to try to delete the editor config using the following path C:\Users\%username\AppData\Local\Unigine\Editor\editor1.1.cfg


Link to post

Hi @bmyagkov,

I just tried deleting the editor config. It did not solve the problem.

Here is the output log, maybe that could help figure out the problem :


---- QtEditor ----
Version: ver-2.6-ed8ee55
Loading "C:/Users/salama/Unigine SDK Browser/sdks/sim_windows_2.6.1.1/bin/unigine.cfg"...
Using config file "C:/Users/salama/Unigine SDK Browser/sdks/sim_windows_2.6.1.1/bin/unigine.cfg"

---- Plugins ----

---- Application ----
Loading "dxgi.dll"...
Loading "openal32.dll"...
ALWrapper::init(): can't load "openal32.dll" library
Set 1600x900 windowed video mode

---- Engine ----
Version: 2.6.1 ver-2.6-ed8ee55 Dec 27 2017
Binary: Windows 64-bit Visual C++ 1800 Release
Engine features: OpenGL OpenGL4.4 OpenGL4.5 Direct3D11 OpenAL XPad360 Joystick DoubleCoords HalfTexCoords Microprofile OpenEXR Geodetic
App path:  C:/Users/salama/Unigine SDK Browser/sdks/sim_windows_2.6.1.1/bin/
Data path: C:/Users/salama/Unigine SDK Browser/sdks/sim_windows_2.6.1.1/data/
Save path: C:/Users/salama/Unigine SDK Browser/sdks/sim_windows_2.6.1.1/bin/

---- System ----
OS: Windows 10 (build 19041) 64-bit
CPU: AMD Ryzen 7 1800X Eight-Core Processor          3593MHz MMX+ SSE SSE2 SSE3 SSSE3 SSE41 SSE42 SSE4A AVX AVX2 HTT x16
GPU: NVIDIA GeForce GTX 1080 x1
System memory: 32698 MB
Video memory:  8192 MB
Sync threads:  15
Async threads: 16

---- MathLib ----
Set SSE2 simd processor

---- Sound ----

---- Render ----
Renderer: NVidia 8079MB
Direct3D11 desc: NVIDIA GeForce GTX 1080
Maximum texture size:    16384
Maximum texture units:   16
Maximum texture renders: 8

---- Physics ----
Physics: Multi-threaded

---- PathFind ----
PathFind: Multi-threaded

Engine base materials loaded: 154 / 154 (40ms)
Engine materials loaded:      52 / 52 (12ms)
User base materials loaded:   19 / 19 (3ms)
User materials loaded:        330 / 330 (122ms)

Loading "core/properties/unigine.prop" 2 properties 0ms

Editor features: VideoGrabber Licensing Landscape FBX Houdini
Loading "libHAPIL.dll"...
HoudiniWrapper::init(): can't load "libHAPIL.dll" library
EditorState::InitInterpreter(): failed to initialize Houdini wrapper
EditorState::InitInterpreter(): failed to create Houdini session
HoudiniAPIHelper::getString(): can't get status string length

EditorState::InitInterpreter(): failed to initialize Houdini API
HoudiniAPIHelper::getString(): can't get status string length

Unigine~# editor_load
---- Interpreter ----
MicroProfile: Web server started on port 1337
Version: 2.90

Loading "core/unigine.cpp" 5ms
Loading "core/locale/unigine.locale" dictionary 0ms
Loading "editor/editor.cpp" 319ms

---- Editor ----
Version: 2.6.1

Loading "editor/locale/editor.locale" dictionary 4ms
Loading "editor/locale/source.locale" dictionary 5ms
Loading "editor/locale/plugins.locale" dictionary 0ms
Loading "editor/locale/systems.locale" dictionary 0ms
Unigine~# filesystem_reload
Raw files: 4161
Unigine~# world_load "test"
Loading "test.cpp" 2ms
Loading "test.world" 71ms

By the way, how can I disable the MicroProfile web server?


Link to post

So, same thing happens with new empty project too, right? Because on my side I can't reproduce same behavior on clear project.

40 minutes ago, karim.salama said:

By the way, how can I disable the MicroProfile web server?

Sad to say but microprofile is a part of binaries on 2.6.1 SDK and your can't turn it off there.

Link to post

Yes, I did some tests on a new world (with the material ball and checkerboard ground). When I move the material ball and try to undo the move action, the editor freezes for a couple of seconds.

Link to post
10 minutes ago, karim.salama said:

Yes, I did some tests on a new world (with the material ball and checkerboard ground). When I move the material ball and try to undo the move action, the editor freezes for a couple of seconds.

Are you running Editor 2? You can check it by clicking "Configure project" at "Other actions" in SDK Browser on "Projects" tab

What exactly API you running - OpenGL or DirectX? Is there any difference if you switch between them? Did you use most recent Nvidia GPU Driver? 461.40?

Link to post

No, I'm using Editor 1.

I did not create a project. I start the editor from [...]\Unigine SDK Browser\sdks\sim_windows_2.6.1.1\bin\editor_x64.exe and create a new world directly into it without creating a project.

I'm using DirectX, all my Nvidia drivers are up to date.

Link to post

How long ago you have face the problem? Has it always been this way or has it starts recently?

Right now, it seems that the problem is on your side, it may be somehow related to a specific hardware, do you run the editor from SSD or HDD?

Link to post

The problem was there from the beginning. I'm using a HDD.

Link to post

Might be connected with HDD, is there any chance to move project to SSD? And what happens if you try to run a current project with a Editor 2?

Link to post

I don't think the problem is due to the hard disk. Once the editor application is loaded into RAM, (normally) it only writes on disk when saving, loading content.

I would like to emphasize that the lag is not present on the 2.5 version of the Unigine Editor.

I have tried installing 2.6.1 on a completely new machine (with an SSD and latest GPU and drivers) and the lag is still occurring.

Sorry for the late response.

Link to post

Maybe there some specific steps to reproduction? Check out attached video, clean project on, undo/redo works as fast as lightning

Hardware is 3900x, 2080ti, WIndows 10 with Unigine SDK on SSD

Link to post

I think I have found the problem!

The lag does not occur when I create a project.

It is only present when I open a .world file directly in the editor.

Do you know why this happens?

Thanks in advance

Link to post

May I ask you to record a video of the problem from beginning? Because we still can't reproduce the problem even if we open the world from the editor and feels like that we are missing something on our side

If you say problem caused only when you open world file straight from editor, what if you trick the editor and run world you need straight from SDK Browser with launcher?

You need to edit "launch_editor.bat" in root folder of your project and change there default world  "unigine_project" to the one you need and then try to launch editor again

Or for example run Editor.exe from command line with argument like -console_command "world_load %name.world"

Might this solve the problem?


Link to post


Thanks for the video.

2.6.x SDK is an old version that is not maintained anymore (except some critical crashes or instability), so I'm afraid this undo-redo issue will stay there.

How to submit a good bug report
FTP server for test scenes and user uploads:

Link to post