How to get back the console starting with VR AppVive plugin?


photo

Recommended Posts

Dear Unigine support,

We do have a weird behavior in VR with the console...

Directly in samples > demos > VR sample, start and ask for console, works fine.

Copy as project > (template empty.. but Oculus and Vive plugin selected) > start with proper args "-console_command "world_load vr_sample/vr_sample" -extern_plugin "AppVive"", and console is not accessible anymore :-o

What do we miss?

Kind regards,
Charles

Link to post

Hello!

We are attempt to reproduce issue on our side but still no success, each case works as expected.

Stupid guess but - what does happens if you switch between language layouts and try ask for console again?

There might be problems when a language other than English is selected

 

Link to post

Hi,

My working language is of course English...

In fact, to run in VR the VR demo of samples, you need to copy it as project and configure it with  -extern_plugin "AppVive" right?

So, with this new project:
- Started by default -> only PC player with mouse/keyboard is used, and console is accessible
- Started with plugin AppVive -> VR player is used, and console is not accessible anymore.

How could it be an issue with language?
PC player is OK, then VR player is KO...
You really don't reproduce it? SDK 2.13.0.1 of course...

Kind regards,
Charles

Link to post

Hello Charles!

We were on holidays for last few days and just got back to work only today.

Quote

In fact, to run in VR the VR demo of samples, you need to copy it as project and configure it with  -extern_plugin "AppVive" right?

In fact you don't need to copy demo as project to run it in VR mode. The only thing you need to tweak is open "Settings" tab at SDK Browser and switch "Stereo 3D" to define your VR headset, see screenshot below 

So you don't need to change anything to run those demo in VR, even when you copy it as project


изображение.png

On 2/22/2021 at 11:55 PM, Lales.Charles said:

How could it be an issue with language?

It might be connected with a specific keyboard layout like AZERTY or QWERTZ where keys are physically has different behavior from what its usually do in the QWERTY layout

Could you please try to run demo as I mention above and tell why you got? We are keep trying to run demo like you do, but even with custom "-extern_plugin "AppVive"" argument everything went fine and console works in a both way

Thanks

 

Link to post

Hi,

Thanks, I learned smthg with the option of SDK ;-)

But it doesn't change that:
- stereo 3D disabled -> console is activable
- stereo 3D HTC Vive -> console is not activable anymore

I keep the same keyboard in between...
You test with Vive and really don't reproduce it?

Kind regards,
Charles

Link to post
25 minutes ago, Lales.Charles said:

You test with Vive and really don't reproduce it?

No success on our side. Same environment - basic 2.13.0.1 SIM SDK and VR Sample running together with HTC Vive Pro, console are shown on PC in a both ways.

Might be you expected to see console on VR helmet? Just saying It's has never worked that way

What about ESC menu? Did it doesn't show up same as console?

Anyways, let's try to do some trick, check out link following link https://developer.unigine.com/en/docs/2.13/code/console/?rlang=cpp&words=console%2Cconsol#intro_change_key

You can remap console on any key you want by editing configuration file here "sdk\demos\vr_sample_demo_2.13.0.1\data\configs\default.user"

Please try to change it from default "96" key to anything you want to and then try to ask for console again, what will happen?

Here is ASCII table below

python-basic-image-exercise-86.png

Link to post

Hi,

Yes it does work if I pick a code that both keyboard have in common / same key, e.g. numbers or . or ,

Other code are not working in VR only, but fine in PC version of the same application..

Where does it come from?

Kind regards,
Charles

Link to post

Hi,

Would it be possible to add in arg -console_command "bind n show" to access the console? Doesn't seem to work...
But if there is a way, we would do -console_command "bind F1 show" or "bind KEY_F1 show" or "bind 277 show"...

277 is code KEY_F1 declared in UnigineApp.. but seems to be ignored if set from configs\default.user... bit pity.

Kind regards,
Charles

Link to post

Hello, Charles!

We got some kind of reproduction, console definitely does not work when you are running French layout in VR mode, but without VR in plain PC mode everything runs smooth, it's still not the same that you are reporting but the result are similar - in VR mode console does not work with a certain layout

AppVive plugin have it's own keyboard mapping and looks like that it's bugged right now, we will improve this behavior in following release, but I need to know following info to be sure that we on a right way:

What is you keyboard? Can I have photo? What exactly layout you have, can you take screenshot on your desktop like this one below?


изображение.png

As for your question - the only way to get this to work now is edit - default.user config and remap console key for code that both keyboard have in common

Link to post

Hi,

Good.

Since I am a French guy working in Germany, I turn my OS English (official language of the company and basically suitable for dev in general) but have to config for German keyboard.

image.png.6c43cfce956cbd9af0484fb1252dcd8a.png

It is QWERTZ layout:

1920px-KB_Germany.svg.png

Common char -> , . not so many...

What about F1..12 keys?
If you check the issue with AppVive or VR, can you please add from default.user your extended ASCII code enum from UnigineApp.h instead of parse only for ASCII code?

Kind regards,
Charles

Link to post