Orientation fbx import parametr doesnt do anything


photo

Recommended Posts

No matter what setting I pick in up axis/front axis dialog, it does not have any effect on mesh after reimport. Bug? Or am I missing something?

Thanks.

Link to post

Hello demostenes,

.fbx reorientation should be working fine, except for cases when selected axis matches with default(which is "z" for up, and "y" for front). Also reorientation could not affect mesh already placed in scene, re-placing reimported fbx might be required so all changes could be applied correctly. 

If nothing of this works, could you please send us the model with which you're experiencing this issue. Also please check engine\editor console log right after reimporting to see if there's any importer errors

Link to post
6 hours ago, vvvaseckiy said:

Hello demostenes,

.fbx reorientation should be working fine, except for cases when selected axis matches with default(which is "z" for up, and "y" for front). Also reorientation could not affect mesh already placed in scene, re-placing reimported fbx might be required so all changes could be applied correctly. 

If nothing of this works, could you please send us the model with which you're experiencing this issue. Also please check engine\editor console log right after reimporting to see if there's any importer errors

Sure, here it is. I ve tried to replace, but no effect. It seems to me that it is the cause you mentioned.

Axe1.fbx

Edited by demostenes
Link to post

fbx_reorient_default.PNGfbx_reorient_yx.PNG

Reorientation of attached works just right on our side. Except for cases in which reorientation is impossible(e.g. when up and front point to the same axis, or default axis). Some UX improvement is required here to reflect the actual functionality of this option. We'll improve it in future updates

  • Like 1
Link to post