Linux minimal system requirements changes: GLIBC 2.24+ is required starting from UNIGINE 2.15 SDK (Summer 2021)


photo

Recommended Posts

Dear customers!

UNIGINE 2.14 release will the be last one with Debian 8 support (which end-of-life date was on June 30, 2020).

The new build environment is Debian 9 (GCC 6.3, GLIBC 2.24), which is backward incompatible with the outdated Debian 8 (GCC 4.9.2, GLIBC 2.19) and Astra Linux 1.5 (also based on Debian 8).

Upgrading the minimal spec will allow us to upgrade some 3rd party libraries (such as Qt) to improve further Editor and SDK Browser behavior and ease the development and further upgrades.

Debian 9 end-of-life is June 30, 2022. So this build environment would also lasts for at least 2 years (if no critical bugs would be found in the compiler behavior, that will force us to upgrade the min spec one more time).

Thank you!

How to submit a good bug report
---
FTP server for test scenes and user uploads:

Link to post