[SOLVED] IG Template Error plz..


photo

Recommended Posts

image.thumb.png.8ceb88ba2b0da7b1b71146730da9ae6c.png

 

I created an IG template and ran it as Hemu, but as shown in the image, a debugging error occurred and it is forced to shut down. What should I do?

Link to post

Hi,

The warning message in orange contains the real explanation: you didn't add any geodetic information to your scenari.

By default, the IG tempalte scene is quite bland, and lacks any geo information. You must either add a GeodeticPivot in the scene (via the Create menu) or create a landscape with the Sandworm tool.

Link to post

YoonMo.Kim

Is there any chance that you have set GDAL_DATA or PROJ_LIB variables?

Can you show us an output of set command from windows terminal (cmd)?

Thanks!

How to submit a good bug report
---
FTP server for test scenes and user uploads:

Link to post

When I create an IG template project and run the editor for the first time,

an error window such as the first image occurs.

 

image.thumb.png.9dca3e6254d0be11ebb428d3ee5789ae.png

 

image.thumb.png.e7598002cefac9e96fa188601a345171.png

Link to post

GPU model is Intel(R) UHD Graphics.

I used the laptop PC.

Edited by YoonMo.Kim
Link to post

We do not recommend to use integrated GPUs for something serious (especially if you want to do some kind of flight sim with large terrain).

Integrated GPU is not very powerful and it looks like it's hanging during the cubemap generation process. Increasing TDR delay may work in some cases. To do that:

  • Go to your registry: Start --> Run --> Type in regedit

  • Go to Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers and:

    • create a key of type DWORD (32-bit) and name TdrDelay with a value of 10 as Decimal value

    • create a key of type DWORD (32-bit) and name TdrDdiDelay with a value of 10 as Decimal value

  • Reboot

10 seconds may be not enough, so you may need to extend it further to something like 30 or 60 or even more.

Thanks!

How to submit a good bug report
---
FTP server for test scenes and user uploads:

Link to post

Another possible solution is to disable GPU textures compression.

You can do it by manually editing the Editor JSON config file that is located in %USERPROFILE%/AppData/Local/Unigine/Editor/editor1.1.cfg. Just add "use_gpu_compression": false, into the assets section at the very beginning of config:

image.png

Save config and restart Editor.

If that doesn't help you need to find more powerful laptop or a desktop PC with discrete GPU.

Thanks!

 

How to submit a good bug report
---
FTP server for test scenes and user uploads:

Link to post

I solved the problem. Thank you!

Link to post
  • silent changed the title to [SOLVED] IG Template Error plz..