Vsync does not work when using AppWall


photo

Recommended Posts

It seems vsync no longer works correctly when using AppWall. I verified that it still worked in 2.5, but in 2.11 and 2.13 I cannot get it to work anymore (I uninstalled the other versions to save disk space so I was unable to verify where it stopped working). My repro is as following:

  1. Open SDK Browser
  2. Under Options, choose 'Wall Auto'
  3. Start the 'Oil Platform' demo
  4. Press Escape, enable fps counter and vsync and press apply

In Unigine 2.5 the framerate dropped to 60fps when I did this, in 2.11 Unigine simply crashes and in 2.13 nothing happens (framerate stays at 125~140fps). When running with Single monitor vsync works fine in all versions.

Link to post

Hello Bemined,

Thank you for your report, actually you can enable vsync, but you can't do it on fly because of the bug, it also affects some other video parameters. I've added this issue to our internal bugtracker.

Meanwhile you can launch wall setup with enabled vsync by using start-up launch argument:

-video_vsync 1

 

Link to post
  • 5 months later...

Hi Vvvaseckiy,

Thank you for your reply. So far the command line argument didnt allow us to get the VSYNC to work. Eventhough, the video_vsync parameter is flagged to be enabled, the FPS doesnt look contant.

Next to this, I am experiencing similar issues with the MaxFPS parameter:

engine.render.setMaxFPS()

At the moment the two issues are blocking us from delivering a stable FPS for an active project. Any help or advise would be much appreciated,

Thank you!

Maarten

Link to post

Hi MaartenM,

The issue is in that all video parameters could not be redefined after launch of application with AppWall plugin. So calling video or render options in AppSystemLogic or AppWorldLogic won't take effect. The only workaround for now is to set them through Startup Command-Line Options. Unfortunately, setting "-video_vsync 1" through console command or by using config file won't work neither. Please make sure that you are launching app with command similar to 
 

unigine_project_x64.exe -extern_plugin AppWall -video_vsync 1

and check if the issue persists

Link to post

Also, could you please specify exact SDK version that you are currently using?

Link to post

Hi,

Thank you for your quick reply. To follow up on your questions:

  • We are currently on version 2.13
  • We do not use the Unigine executable directly, but have our own launcher exe that creates the Unigine::Engine using the Unigine API. The command line arguments that we use are passed to the Engine via the constructor. Looking at our logs they are provided before the first call to setting VSYNC.

Also, this will not solve the issue with the MaxFPS as there is no command line argument, nor console command equivalent for this one, at least to my knowledge. So it relies on being called through code. Is it a known issue or limitation?

Thanks,

Maarten

Link to post
Quote

Also, this will not solve the issue with the MaxFPS as there is no command line argument, nor console command equivalent for this one, at least to my knowledge. So it relies on being called through code. Is it a known issue or limitation?

Unfortunately. Yes. It is known issue, it's not only for maxFPS, but for all other video settings.

Regarding the problem with vsync & AppWall, i've PM'd you appwall sources with force-enabled vsync

Link to post

Thank you for the PM. I will be able to continue with this next week.

Link to post