Migration 2.11 to 2.12


photo

Recommended Posts

Hello,

I am migrating to 2.12 version right now.

I fixed all api changes and changed config files from unigine.cfg to default.boot.

But I am getting only a white picture for directx and opengl.

We are managing opengl and directx context and application window by ourselves. Did anything change in graphics api usage?

GPU usage is 100 % so it is rendering something but it is not swapping to the front buffer.

Thanks

Link to post

Hi Sebastian,

Not all the custom apps may work correctly with new boot screens. You can switch your custom app into the legacy mode by overriding isLegacyMode() flag:

int isLegacyMode() const override { return true; }

 

How to submit a good bug report
---
FTP server for test scenes and user uploads:

Link to post

Hey Sebastian,

we did also have some issues when migrating to 2.12.
CustomApp::setVideoMode will now also be called for the boot screen. So make sure your old code is not called too early.

Best regards

Link to post

@silent thanks but i am still in white hell.

I can open the console and show the profiler. Everything else remains white.

 

@devrom what do you mean with too early? Our overidden setVideoMode will do nothing, because we are managing directx and opengl contexts and windows by ourselves. The Graphics API is already initialized, when we are initializing the engine. Thanks.

Link to post

Well, when and how do you tell Unigine which context it should use?

Link to post
19 minutes ago, devrom said:

Well, when and how do you tell Unigine which context it should use?

You can call initGL or initD3D11 on your custom app with your created context parameters. This happens before you give your app as parameter to the Unigine::Engine::init static method. Unigine automatically initialize its resources then.

Link to post

sebastian.vesenmayer

Is there anything displayed in the rendering buffers? Could you show the render_show_textures 2 output?

If you can see the profiler and console the context is being used correctly.

How to submit a good bug report
---
FTP server for test scenes and user uploads:

Link to post

grafik.thumb.png.b4797caff2c063446f381c38dadb3200.png

grafik.thumb.png.0a486ce59f29eb259dc5a6a1840f0ba7.png

@silent no the textures are not visible, but frametime changes when I activate render_show_textures 2, so it has to be somewhere.

Link to post

I will prepare a example project for you, maybe i am doing something completly wrong.

Link to post

I stripped down our implementation, now I am able to see the render buffer textures. So we are doing something incompatible with the new version, we have to debug this further, but context usage works as expected.

Thanks.

  • Thanks 1
Link to post

We found the issue in our code, accidently the gui has been drawn full screen in a parent development branch which caused this behavior.

 

We are now checking all of our particle systems. But some of them do not work properly anymore (direction, velocity, shading) .

Is there a guide to get the same particle effect behavior from 2.11 ?

Are track files automatically translated to new particle system settings or do we need to update every effect manually?

Link to post

Glad that you resolved this rendering issue.

 

Quote

We are now checking all of our particle systems. But some of them do not work properly anymore (direction, velocity, shading) .

It's impossible to migrate some particle systems due to the new curves feature, so you may need to fix (or in some cases with attenuation texture - re-implement) them manually.

There also was no migration written for the *.track files after new particles parameters were added, so you will need to migrate these tracks on your own.

How to submit a good bug report
---
FTP server for test scenes and user uploads:

Link to post