[SOLVED] Light not passing through the semi-transparent objects


photo

Recommended Posts

Hello,

I had a scene of the room interior with semi-transparent glass on windows and seems they do not pass the sun light (LightWorld) through them. I then tried a simple test in editor, where I made a glass wall (alpha blending mode enabled and Albedo alpha set to 100) and put Omni light in front of it. I only see the light spot on one side of the glass. I expected it to illuminate the wall that is behind the glass, at least to some degree. When I enabled translucency, light spot appears on the other side, but still the light is not passing through it (the wall does not get illuminated). Could you tell me how to achieve this effect? Thanks! 

omni1.PNG

Omni2.PNG

OmniTranslucency.PNG

Edited by elisagroup
Link to post

elisagroup

Looks like you need to disable Cast Proj and Omni Shadows option at the Common tab.

image.png

Alternative solution is to use additional State - Transparent Shadow.

image.png

But this approach may have some rendering artifacts.

Thanks!

  • Like 1

How to submit a good bug report
---
FTP server for test scenes and user uploads:

Link to post

Worked like a charm, thank you, sir!

Edited by elisagroup
Link to post
  • silent changed the title to [SOLVED] Light not passing through the semi-transparent objects