photo

down below 45fps.

Recommended Posts

image.thumb.png.2ba3cd267578abcf5b9f285c9fb61bb8.png

image.thumb.png.05575c5ebc2d11180492bb980f386e06.png

 

vr plugin update is too long.

Does the graphic things load affect the cpu?

What do you think would be good to check? There are no objects other than terrain, hands, and first-person helicopters.

help...

Share this post


Link to post

Hello Dong Ju,

Have you tried disabling/enabling objects in the scene to identify the one that slows the rendering? Which plugins you're using, by the way? Is it still 2.9 with Syncker, AppVive and leap motion?

Thanks.

Share this post


Link to post

yes, I use 2.9 and  arguments -data_path ../ -engine_config "../data/unigine.cfg" -console_command "render_stereo_reprojection 2 && render_stereo_hidden_area 1" -extern_plugin "AppVive,LeapMotion,IG,CIGIConnector"

Hardware Spec :  Ryzen 3600x, 16GB Ram, GTX1660Ti

 

I ran this program directly from the Unigine SDK browser.

image.thumb.png.2c78cedc50c3939be6adbf049ff9ead1.png

image.thumb.png.3ce82e95261414baf313c4074694a8d8.png

this is Immediately after loading the world with Hemu, there are no objects. Periodically the frame is reduced to 45 fps.

 

==================================================================================================================================

image.png.70008a54fe8753dbb02ab34ab7dc6a68.png

image.png.d9893f57ec41288fb219ecb4a1216cda.png

This is the terrain added.

 

===============================================================================================================================

image.thumb.png.37f9f399e2db21fbf4ba34a08feb50d3.png

image.png.223549960642bb7ddb12ac1746eae77d.png

This is also a helicopter addition.

I tried to optimize the shadow of the helicopter as much as possible, but it still has a lot of polygons and materials.

Share this post


Link to post
3 hours ago, dongju.jeong said:

yes, I use 2.9 and  arguments -data_path ../ -engine_config "../data/unigine.cfg" -console_command "render_stereo_reprojection 2 && render_stereo_hidden_area 1" -extern_plugin "AppVive,LeapMotion,IG,CIGIConnector"

Have you tried to find out which plugin is the slowest? I also must say that GTX1660 is rather slow GPU for VR rendering.

Share this post


Link to post

Slowest plugin is AppVive. and next IG-CIGI.  However,  plugins other than AppVive are not very slow.

 

Is this problem just by using low-performance GPUs and heavy objects?

Share this post


Link to post

I think that we're talking about SteamVR capping the frame rate. Didn't we discussed this before? If the system can't produce 90 fps SteamVR drops it to 45. As a rule this stall is shown as "Plugins update" in the microprofiler charts. According to your test AppVive causing the major slow down, so the problem is in the rendering speed.

Just try to degrade rendering resolution with console command "render_supersapling 0.2" and check the frame rate and plugins update value. If it raises the issue in the GPU performance.

Thanks.

  • Like 1

Share this post


Link to post

Thank you. I remember the reason for dropping to 45.

In microfiler, Plugins update is located in the information on the cpu(Main) side, so I had just wondered there was another problem.

 

When I lowered the resolution, I saw that the frame was raised.

 

350 materials, 400 surfaces increase one model is a very bad model design??
(When checked in Performance Profile-Rendering)

This is the case with our first person helicopter or jet model.

Share this post


Link to post
44 minutes ago, dongju.jeong said:

350 materials, 400 surfaces increase one model is a very bad model design??

It's not that much. If you have time it's better to merge materials and use texture atlases, you'll get fewer materials. However, I think the GPU can't handle the scene in VR.

Thanks.

 

  • Like 1

Share this post


Link to post

thank you.

Share this post


Link to post