Landscape Problem


photo

Recommended Posts

Hello

I am newbie for UNIGINE Engine.I am not sure about its bug or my mistake. I wanted to try Landscape tool but graphics looks like glitching while using that tool. Creates random holes and positions get changed random while using height paint. I tried different values for opacity and height but same result sometimes landscape gets invisible while using landscape tool.

I recorded a video : https://streamable.com/qqyjaf

I am using Debian 10 x64

Link to post
11 hours ago, rdhb.rdhb said:

Hello

I am newbie for UNIGINE Engine.I am not sure about its bug or my mistake. I wanted to try Landscape tool but graphics looks like glitching while using that tool. Creates random holes and positions get changed random while using height paint. I tried different values for opacity and height but same result sometimes landscape gets invisible while using landscape tool.

I recorded a video : https://streamable.com/qqyjaf

I am using Debian 10 x64

Hello!

We need more information on this: OS, CPU/GPU, Driver version, steps to reproduce and the heightmap if possible. I guess you are on AMD with MESA driver?
As well as AMDGPU-PRO driver wouldn't help much since AMD + OpenGL bundle not recommended for working with Landscape Terrain

  • Like 1
Link to post

Yes you are right i am on AMD with MESA driver

CPU/GPU : Ryzen 3700X and RX 570

OS: LMDE 4  MESA version 20.0.7 (MXLinux ahs repo)

i also made an experiment with Linux Mint 20 with MESA 20.1.4 (kisak ppa) version but unfortunately still got same glitches

Link to post

rdhb.rdhb

Unfortunately, AMD driver (either proprietary or Mesa) is not capable of proper OpenGL multi-threading resources streaming, so it's currently not possible to get correct Landscape Terrain brushes behavior.

The situation may change with Vulkan implementation. Alternatively, you can try to use dxvk and run UNIGINE for Windows in Wine (but Windows is required for that).

Thanks!

  • Like 1

How to submit a good bug report
---
FTP server for test scenes and user uploads:

Link to post

Yes i confirm terrain glitch with amd card, there is no problem with nvidia card.

  • Like 1
Link to post