Sign in to follow this  
photo

[SOLVED] very slow start on some HW

Recommended Posts

Posted (edited)

We ve noticed, that on some HW start of editor is very slow (not the first start, so there is no generating of .runtime folders). For our project it usually takes cca 20-30 seconds (Ryzen based workstations, 9-10th generation of Intel...), which is OK, but on some machines it can be even 6 minutes, especially "inicializating engine" phase can tak up to 4 minutes. Only difference with these machines are older generations of CPUs (6th, 2nd, etc...), GPU, memory and HDD are very similar (1070+, 16GB+, SSDs). From CPU performance point of view there is absolutely no reason, why should be 6th generation 10x slower than 9th. I also remember, that it was OK some time ago (several months ago). On the video bellow you can see, that system is not fully loaded, hdd also does nothing. To compare, my Ryzen 9500x has  during start (20-30 sec) similar usage values for HDD and CPU usage around 5 percent, so it is not about using rough cpu power. Could it be, that you switched to some newer compilator, which does not support older CPUs?  Thanks.

Here is video of such slow start:

 

Edited by demostenes

Share this post


Link to post

Hi Jirka,

Start-up times depends on number of files that are located in the data directory and all the mounted locations.

Windows Defender application with enabled real-time protection can significantly slow down the file access operation (and also consume some CPU time). Adding your project's data and all the mounts directories to the exclusion list can give you a huge boost in Editor and Engine start-up times (up to 2-5x). However, it's not really noticeable on a small projects (less than 10K files in total).

You can also set exclusions via elevated Powershell by running following command:

powershell -inputformat none -outputformat none -NonInteractive -Command "Add-MpPreference -ExclusionPath 'C:\Unigine Projects\My Project 1\data'"

Thanks!

Share this post


Link to post

Thanks a lot for your assistance, it was really caused by Defender.

Share this post


Link to post
Sign in to follow this