Widgets not useable when using ALIGN_BOTTOM or ALIGN_RIGHT


photo

Recommended Posts

Hi,

it seems there is an problem with child widget-usage when the parent one is attached to the main gui via addChild with either ALIGN_BOTTOM or ALIGN_RIGHT. I reproduced the bug also in 2.10.0.2.

Short steps to reproduce:

  1. Open the existing C++ project "WidgetCallbacks" in the Widget folder of the C++ example projects.
  2. Modifying line 51 by changing addChild() parameters with eiter ALIGN_RIGHT or ALIGN_BOTTOM.
  3. Run -> no button interaction and window won't be repositioned.

This bug also happens when those two alignment-parameters are called in combination with other ones. So ALIGN_LEFT | ALIGN_TOP will work, but ALIGN_LEFT | ALIGN_BOTTOM won't.

 

Best

Christian

Link to post
  • 2 weeks later...

Hello,

In this case, with flags you need to use ALIGN_OVERLAP. This flag makes the window movable. Also it affects the alignment of elements.

Link to post

Hello karpych11,

yes I was aware of that ALIGN_OVERLAP statement. But I didn't know it was intended because seems a little bit confusing when using ALIGNE_LEFT | ALIGN_TOP will work without any problems while using ALIGN_RIGHT or ALIGN_BOTTOM in any combination don't.

Link to post

Yeah, there always a room for improvements (in internal GUI framework). We will think how can we improve this behavior in the future SDK updates.

Thanks!

How to submit a good bug report
---
FTP server for test scenes and user uploads:

Link to post