Sign in to follow this  
photo

Gizmo are always shown for NodeReference content

Recommended Posts

Hello,

If a NodeReference content contains a Field, a Player, or anything alike that has a Gizmo (eg. the frustum of a player), then when the NodeReference is placed in the world, all its Gizmo are visible, ignoring the preference in Helpers/Gizmo.

This can be particularly annoying when a ref has a lot of Players or fields, because the screen get cluttered very fast.

If this is on purpose, then maybe an option "show gizmos inside NodeReference" should be added.

Thanks!

Share this post


Link to post

Hi Stephane,

Which SDK version are you currently using? Could you please show us a screenshot from editor with these NodeRefrences and gizmo's settings?

Thanks!

Share this post


Link to post

SDK is 2.12a (but the behavior was similar in previous version).

Here is a snapshot of a demo Ref reference node with a few camera inside:

image.png.954a14a0b3ba97d8e2626a2d675c08d9.png

Here are the gizmo helpers settings (all are unchecked):

image.png.20dc43fed100191e67046a6967f0b710.png

Here is the screen when the Ref is opened (same gizmo settings):

image.png.3ae7a26845c129281481dbf483de2362.png

The gizmo are now invisible (as per the settings).

Share this post


Link to post

Hello, can you confirm this behavior should be fixed? (not urgent of course). Thanks!

Share this post


Link to post

Hi Stephane,

As far as I understand this is expected behavior and it's preset in all the previous engine versions. I need to discuss this behavior change with our 3D artists first. We will take a closer look at this after 2.12 SDK update.

Share this post


Link to post
Sign in to follow this