Particles emitter does not "start" on Master


photo

Recommended Posts

Hello,

I added a basic particles emitter on one of my Cigi entities. When the entity is instanced, the particle emitter does not start on the master, but it does start on the slaves, strangely.

There is no code at all managing the entity, it's just a basic node listed in the entity_types.xml for cigi. The particle emission is of course enabled by default, the node itself is enabled, and it's at the root of the node.

Am I missing something obvious?

Link to post

Amerio,

Sorry for the late reply. Could you please provide a small test scene with that behavior? Can it be reproduced with our CIGI demo and Host emulator?

Thanks!

How to submit a good bug report
---
FTP server for test scenes and user uploads:

Link to post

Here is attached a minimal test scene, with HEmu files (Entities.def and Terrain.def). Just add the "particles" entity type #1.

(bin an core.ung removed for size consideration)

test.7z

Link to post

Hi Amerio,

Double checked your test sample and it seems everything is working just fine. Steps are:

  1. Unpack archive;
  2. Modify launch_release_master.bat to set the -sync_broadcast_address 127.255.255.255
  3. Run master first, than slave
  4. Run CIGI Host Emulator
  5. Create a plane with Type 0 and location 43.43379374 5.22000000 1.00000

    image.png

How to submit a good bug report
---
FTP server for test scenes and user uploads:

Link to post

Actually you are right in the the test case you described, because you launched HEmu after the IG, the particle emitter does indeed start correctly. 

In the test I ran (which behaves more like what we have here in real life), the host is already running when the IG is run, so you should test with:

(sorry for having been imprecise in the original post)

  1. run HEmu and add Ownship type 0, then add Particles type 1 somewhere in front of ownship
  2. run master (no need to run the slave)
  3. In HEmu, select Ownship and press Enter with the focus on position/Altitude (this will reposition the ownship in Unigine)
  4. In HEmu, select Particles and press Enter with the focus on position/Altitude (this will reposition the particles entity in Unigine) => and the particle emitter doesn't start

I also found that if the Ownship is type 1 (the particles) then they do start on the master. It just doesn't start if they are another entity.

Link to post

I don't know why, but CIGI Host Emulator sends Entity Control packet with Animation State: Stop (0) value by default (or not?). This is the cause of disabled particles.
To enable it, send Entity Control packet manually.
In CIGI Host Emulator: Actions -> Send Packet -> Entity Control...
Change Animation State to Continue (or Play) and press the Send button. Particles will be appear.

I think HEmu works very strange and unstable if it starts before IG. For example, it doesn't send "View Definition" packet about "Group 1: OTW" if you run it before IG.

Best regards,
Alexander

Link to post

You are right ! I was having the same behavior with our own host (not just HEmu) because we also send the Anim in STOP state. Now that is quite interesting because it means we have a mean to control the emission directly, no need for a Component Control :)

So that solve it for the master. The remaining question here is why is it always started on the slave while the Anim STOP is send ? Is it some inconsistencies/network sync issue ? or something else I missed ?

 

Link to post