Qt 5.10 platform webgl and the Qml UnigineItem


photo

Recommended Posts

Hi !
I've just tried the new feature of Qt 5.10 witch is webgl streaming  the Qt app to a browser without touching the code (just pass "-platform webgl" flag to the executable).

For this I've tried to compile the Unigine's App/Qml sample with Qt5.10 to test it but (as expected) doesn't work.

I have no idea if the problem comes from Unigine, from the integration or from Qt itself but I think this feature can be very interesting to have.

I post here the steps to reproduce the crash if it can help :

- Removed qt folder and qt.conf
- Copy libUnigine_x64.so to the App/Qml folder
- Run qmake from Qt 5.10 than make
- Run the executable
    ./Qml -data_path ../../../../../ -data_path ./ -platform webgl

- Browse to http://localhost:8080 than ... crash
    QObject: Cannot create children for a parent that is in a different thread.
    (Parent is UnigineItem(0x1aa2780), parent's thread is QThread(0x1a278c0), current thread is QSGRenderThread(0x1ab3790)

(Any other apps that don't use Unigine are working fine)

Link to post

Hi Christophe,

That's indeed interesting feature, but since it's still beta (or alpha) I would wait until the more stable behavior. Is there any difference if you will run engine with OpenGL / DirectX API? Does it compatible with OpenGL 4.5 core profile applications (like our engine)?

Thanks!

How to submit a good bug report
---
FTP server for test scenes and user uploads:

Link to post