Cannot start a project via SDK browser and Game Framework acting up


photo

Recommended Posts

Hello, 

  I am currently in charge of a team evaluating Unigine 2.2.1-2 SIM. I am having issues with starting up projects inside of the SDK browser. I can however go to the project folder and start it via the batch file provided (as long as the SDK browser is open for licensing verification). Any clue why this might be happening?

 

post-2233-0-93374300-1467227872_thumb.gif

 

 I am also having an issue where the Editor Game Framework is not acting correctly. I create a game, save. I then create a level, and save. I then create an entity and save. Everything seems to be acting correctly then out of the blue I will start up Unigine and when I try to open the game file, the Game Framework window is empty. I can still go and check the %name.game file and see all of the files tied to it.. I have tried re-installing the SDK browser, and can confirm this is happening on multiple projects. I am unsure however if this might be due to the previously mentioned issue. 

 

 

post-2233-0-83723100-1467228635_thumb.gif

 

 

I must be missing something. Thank you for your help.

 

OS just incase insider builds don't work correctly with the browser.

Windows 10 Pro Insider Preview build 14366.rs1_release.160610-1700

Edited by cody.petitjean
Link to post

Quick update. The issue with opening projects via SDK Browser still exists. 

 

The second issue with the Game Framework however, I seemed to have fixed. I have since downloaded the full SIM Evaluation (3.1GB) from the website instead of through the SDK Browser. 

Link to post

Hello,

 

The issue with opening projects via SDK Browser still exists.


This issue could be related to Windows privacy policy or antivirus protection. If you are using some kind of antivirus protection - it is better to add browser.exe and browser_x86.exe to the exclude list.   

To say more specific we need to check browser logs. Please, provide us browser.log and update.log(if exists) from %userprofile%/AppData/Local/UNIGINE_SDK_Browser directory.

SDK Browser cache is also located inside %userprofile%/AppData/Local/UNIGINE_SDK_Browser directory. In case of some issues, you can try to remove it completely and launch SDK browser again.

 

Link to post

hello

project start with batch-file correctly and do not started from sdk-browser, only - right?

do you have this problem with all projects that you created?

do you have similar problems with start the unigine demos or script samples (tab Samples - Unigine Script) from sdk-browser?

also, please give us information about use antivirus / firewall (if you use it). thanks

Link to post

hello

project start with batch-file correctly and do not started from sdk-browser, only - right?

do you have this problem with all projects that you created?

do you have similar problems with start the unigine demos or script samples (tab Samples - Unigine Script) from sdk-browser?

also, please give us information about use antivirus / firewall (if you use it). thanks

1) Yes. It does start up with the batch file, but will NOT start using the SDK Browser.

2) Every project that I create I have this problem with.

3) I cannot launch scripts or demos through the SDK Browser.

 

Antivirus: Windows Defender -> Permitted use of Unigine Browser and editor / player.

Firewall: Windows firewall -> Permitted use of Unigine Browser and editor / player.

Link to post

Also having MAJOR issues with materials not saving / working correctly. I would be more than happy to continue helping you guys out with windows 10 issues. I will try to get off of the Windows 10 Pro Insider Previews tonight and just run default windows 10. Looks like I have to buy windows 7 now  :(

Link to post