[SOLVED] Some issues with websocket server in Unigine beta2


photo

Recommended Posts

Hi,

 

I use the webserver class found in portangeles demo, but in beta2  there is disconnection when the web page at client side receiving data from unigineScript.

 

Also, i updated buffer to blob class, Is there other migration to be done?

when i received data, the server close the connection (op_code ==8)

// close connection
if(op_code == 8) {
	//log.error("close connection op_code == 8\n");
	socket.close();
	return "";
} 

thanks.

 

UNIGINE_Sim_src_win_2.0-beta2

 

 

server.h

Link to post

Hi Abdelfettah,

 

According to the RFC 6455 specs opcode %x8 should close the socket. Please, check your web browser data that was send to the server.

We can check this also if you can prepare a small test scene with reproduction.

 

Thank you!

How to submit a good bug report
---
FTP server for test scenes and user uploads:

Link to post

Hi Abdelfettah,

 

As we expected, you are closing the socket in remote.html (function onMessage(evt)). Please, consider to remove websocket.close(); to avoid disconnections.

 

Thanks!

How to submit a good bug report
---
FTP server for test scenes and user uploads:

Link to post

Yes, indeed, i haven't seen this bug, thanks,

 

But there is another limitation of message's size in sending with web client, i can't send more than 150 characters.

 

Thanks.

Link to post

Hi Abdelfettah,

 

In our implementation we don't support messages with Payload length more than 7 bits (we just don't need them in our Portangeles demo). Please, consider to extend server functionality according to the RFC 6455 specs if you need to read bigger messages.

 

Thanks!

  • Like 1

How to submit a good bug report
---
FTP server for test scenes and user uploads:

Link to post