[SOLVED] Error when importing .mesh files to Max


photo

Recommended Posts

I get an error when trying to import a .mesh file into 3ds Max 2015. The first time I ran the plugin, it worked fine, then I restarted max and now I get this error: "--Type error: Call needs function or class, got: undefined". I reinstalled the plugin from the latest tools download, but no change. In Max 2014 when I try to import a .mesh file it just crashes Max entirely. 
 

Any suggestions?

Link to post

It happens with every file that I've tried. Here's one of them. 

 

This is a big problem. I need to import a few key mesh files, and I can't, because this is a proprietary format and it's not supported properly. It's a big roadblock in what I'm doing right now.

DetailsMesh.rar

Link to post

In fact, it won't even open the file choosing window, the plugin just breaks immediately.

Link to post

Hi,

 

Thank you for the test file.

 

MeshViewer tool (<SDK>/bin/ResourceEditor) can save *.mesh files into *.obj (that can be opened by any modern DCC tool). I will check this .mesh file with 3ds Max plugins tomorrow.

 

Sorry for the inconvenience caused.

How to submit a good bug report
---
FTP server for test scenes and user uploads:

Link to post

I don't see that option. Looks like I can save and export mesh files from the MeshViewer to mesh, smesh, and sanim only.

Link to post