Network Plugin Issue(-extern_plugin problem)


Recommended Posts



I've been trying to create a simple network sample by following the steps in Documentation/RakNet Network Library Integration via Raknet Plugin/Network Sample.


When I tried to execute launch_debug file in the project folder I got the following error message:  void init (NetworkAddress server_address_) {

C:/Unigine evaluation/data/network/samples/common/scripts/statistics/statistics.h:38 Interpreter::parse_user_function_prototype():unknown type of argument "NetworkAddress" in "init" function World::loadWorld(): can't load "network_01/network_01.cpp" world script.


Having searched for this particular error I came across with a similar error message in "" topic. As far as I understood the solution is to load the Network Plugin by simply typing main_x86d (or x64d for 64 bit?) -extern_plugin Network in the console. However, when I typed that command an error message "unknown command main_x86d" was displayed. Moreover, I tried -extern_plugin and several different combinations that I've seen in the forums or documents but none of them seemed to work. How can I fix this problem? Thanks in advance.

Link to post


You can create a new project with RakNet library integration (SDK browser -> New Project tab -> Misc -> RakNet library integration checkbox) to simply run the engine with Network plugin.
If you'll create console script launchers for the project it would help to check what set of console commands is needed.

Then you can add script logic into <New project folder>/data/my_project/my_project.cpp

If it will not help, for any specific advices your sample is needed.

Link to post