[SOLVED] How to load network plugin(sim version)


photo

Recommended Posts

In my world, i want to use network_x64.dll like this: -extern_plugin network. Dut i can not load it because  of " bad  "network" plugin version 0x000400d 0x1000400d".

 

My Unigine version is:

#ifdef UNIGINE_DOUBLE

  #define UNIGINE_VERSION 0x1000400d

#else

  #define UNIGINE_VERSION 0x0000400d

#endif

 

 

What should i do that i can load the plugin? thanks

 

Link to post
  • 3 months later...

Hi,

 

Unfortunately, Network plugin works only with float precision binaries.

can i make a double precision binaries with recompiling ?

Link to post

Hi,

 

This is possible. However, we can not guarantee stable work in this case.

 

You need to modify <SDK>\source\plugins\Network\RakNet\source\SConscript file on line 59:

 if g_double:
  defines += ' USE_DOUBLE'

to:

 if g_double:
  defines += ' USE_DOUBLE UNIGINE_DOUBLE'

And rebuild Network plugin via scons double=1.

 

Thanks!

How to submit a good bug report
---
FTP server for test scenes and user uploads:

Link to post
  • 1 month later...

Hi,

 

This is possible. However, we can not guarantee stable work in this case.

 

You need to modify <SDK>\source\plugins\Network\RakNet\source\SConscript file on line 59:

 if g_double:
  defines += ' USE_DOUBLE'

to:

 if g_double:
  defines += ' USE_DOUBLE UNIGINE_DOUBLE'

And rebuild Network plugin via scons double=1.

 

Thanks!

 

Hi, i type  "scons double=1" on command in <SDK>\source\plugins\Network\RakNet\, but some errors have shown as shown in the picture. what can i do to solve it ?I have sent the error image in email.

 

Thank you~

Link to post