[SOLVED] SpeedTree Plugin unable to load


photo

Recommended Posts

Hello everyone.

 

I obtained a SpeedTree plugin for Unigine a few days ago, however, I am having a few issues with loading it. 

 

Unfortunately the plugin didn't come with any type of documentation explaining how to install it. It did however, contain a few files which were copied to their respective directories. After copying the files, I then used the 'Import Plugin for Collada' as guideline. Unfortunately, when I run the editor and open 'Tools' - 'Plugins' - 'Core' I get an error message stating 'SpeedTree plugin library is not loaded' 

 

If you guys have any suggestions it would be much appreciated.

 

Thanks

 

Ryan.

post-1257-0-70483900-1391600324_thumb.jpg

Link to post

Hi,

 

Just copy SpeedTree's *.dll files into <SDK>/lib directory and extract editor_speedtree.bat from attached zip file to the <SDK> directory (where browser.bat file is located). After that you can start editor with SpeedTree plugin via editor_speedtree.bat launcher.

 

Thanks!

editor_speedtree.zip

How to submit a good bug report
---
FTP server for test scenes and user uploads:

Link to post

Unfortunately I have now stumbled across another error. When I try to import the .SRT model I get an error that states:

 

 "SpeedTreeImport::load(): can't load "Finaltest" file CParser::ParseHeader, expected header[sRT 05.2.0] but got [sRT 06.0.0]"

 

Do you guys have any suggestions as to what I could be doing wrong?

 

Many thanks

 

Ryan

 

 

post-1257-0-74399800-1391613069_thumb.jpg

Link to post

Thanks again Silent.

 

I'll get in touch with SpeedTree to see if there is anything they can do for me. 

 

Do you guys intend on adapting the plugin to make it compatible with version 6 any time in the near future?

 

Thanks.

Link to post
  • 2 months later...