Jump to content

Search the Community

Showing results for tags 'load'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to UNIGINE Forums
    • News & Announcements
    • Getting started
  • Development
    • Content Creation
    • World Design
    • Rendering
    • Animation
    • Physics, Navigation and Path Finding
    • UI Systems
    • Sound & Video
    • Editor
    • C++ Programming
    • C# Programming
    • Networking
    • Sim IG (Image Generator)
    • VR Discussions
    • General
  • Improving UNIGINE
    • Documentation
    • Feeback for UNIGINE team
    • Bug Reports
    • Unigine SDK Beta feedback
  • Community
    • Collaboration
    • Tools, Plugins, Materials & Tutorials
    • Showcase
    • General Discussions
  • Legacy
    • UnigineScript

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 2 results

  1. Hi, When loading my created mesh objects which I saved before there are no normals anymore in the mesh object. Here is a reproducer: { auto mesh = Unigine::Mesh::create(); mesh->addSurface("0"); mesh->addVertex(Unigine::Math::vec3(1.f, 1.f, 0.f), 0); mesh->addVertex(Unigine::Math::vec3(1.f, 0.f, 1.f), 0); mesh->addVertex(Unigine::Math::vec3(0.f, 1.f, 1.f), 0); mesh->addNormal(Unigine::Math::vec3(0.f, 0.f, 1.f), 0); mesh->addNormal(Unigine::Math::vec3(0.f, 0.f, 1.f), 0); mesh->addNormal(Unigine::Math::vec3(0.f, 0.f, 1.f), 0); mesh->addIndex(0, 0); mesh->addIndex(1, 0); mesh->addIndex(2, 0); auto numVertex = mesh->getNumVertex(0); auto numNormals=mesh->getNumNormals(0); std::cout << numVertex << numNormals << std::endl; mesh->save("hello.mesh"); } { auto mesh = Unigine::Mesh::create("hello.mesh"); auto numVertex = mesh->getNumVertex(0); auto numNormals = mesh->getNumNormals(0); std::cout << numVertex << numNormals << std::endl; } It affects versions 2.7.2.1 to 2.8.0.1. Thanks, Sebastian
  2. Hello, I am working to establish an effective pipeline for landscape creation for our work environment(Using Unigine 2.7.1). We use P4V for source control and have run into an interesting hiccup regarding read-only files. After landscape generation, the landscape and world look fine on my local machine. However upon pushing the files to the P4V Database, my local files become read-only unless I check them out from P4V. This is where we ran into the hiccup. Once the local .uts and .utsh files are pushed to the Database and marked Read-only, upon startup of the level, the engine fails to load them properly. I tested several cases and it appears that it requires write permission in order to properly load the .uts and .utsh files and display the landscape. This is true for all PC's that sync the world and landscape content to their local files. Each needs to check-out the files, flagging them as write-enabled, in order to load the landscape. This was also able to be replicated without using P4V, by simply using Windows Explorer to mark the .uts and .utsh files as read-only. Naturally we would like to avoid this file check-out clutter in our process, however I understand that this may be a misunderstanding as I am still learning Unigine. I'm interested in any thoughts that could help or shed light on the situation with .uts and .utsh file types. Thank you!
×
×
  • Create New...