Jump to content

Search the Community

Showing results for tags 'ellipsoid'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to UNIGINE Forums
    • News & Announcements
    • Getting started
  • Development
    • Content Creation
    • World Design
    • Rendering
    • Animation
    • Physics, Navigation and Path Finding
    • UI Systems
    • Sound & Video
    • Editor
    • C++ Programming
    • C# Programming
    • Networking
    • Sim IG (Image Generator)
    • VR Discussions
    • General
  • Improving UNIGINE
    • Documentation
    • Feeback for UNIGINE team
    • Bug Reports
    • Unigine SDK Beta feedback
  • Community
    • Collaboration
    • Tools, Plugins, Materials & Tutorials
    • Showcase
    • General Discussions
  • Legacy
    • UnigineScript

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 1 result

  1. Hi, just tried to let the clouds vanish at the horizon. When using the c++ api, only the standard value of 6378.137 km is working correctly for the ellipsoid of the GeodeticPivot. When I slightly change it the clouds will vanish. I am using OpenGL and Unigine 2.7.2.1. m_cloudsGeodetic = Unigine::GeodeticPivot::create(); m_cloudsGeodetic->setOriginBasis(Unigine::GeodeticPivot::ORIGIN_BASIS_LOCAL); auto ellipsoid = m_cloudsGeodetic->getEllipsoid(); ellipsoid->setMode(Unigine::Ellipsoid::MODE_FAST); ellipsoid->setSemimajorAxis(6378137.); //coverage normal //ellipsoid->setSemimajorAxis(6378137.-500.); //coverage gets higly reduced //ellipsoid->setSemimajorAxis(6378137.+500.); //coverage normal //ellipsoid->setSemimajorAxis(6378137.+1000.); //no clouds visible anymore .... m_cloudsGeodetic->addChild(cloudLayer->getNode()); Did I miss something or is it a bug? Thanks Sebastian
×
×
  • Create New...