Видеоуроки
Interface
Essentials
Advanced
Полезные советы
Принципы работы
Свойства (properties)
Компонентная Система
Рендер
Физика
Редактор UnigineEditor
Обзор интерфейса
Настройки и предпочтения
Работа с проектами
Настройка параметров узла
Setting Up Materials
Setting Up Properties
Освещение
Landscape Tool
Sandworm (Experimental)
Использование инструментов редактора для конкретных задач
Extending Editor Functionality
Программирование
Основы
Настройка среды разработки
Примеры использования
UnigineScript
C++
C#
Унифицированный язык шейдеров UUSL
File Formats
Rebuilding the Engine Tools
GUI
Двойная точность координат
API
Containers
Common Functionality
Controls-Related Classes
Engine-Related Classes
Filesystem Functionality
GUI-Related Classes
Math Functionality
Node-Related Classes
Objects-Related Classes
Networking Functionality
Pathfinding-Related Classes
Physics-Related Classes
Plugins-Related Classes
IG Plugin
CIGIConnector Plugin
Rendering-Related Classes
Работа с контентом
Оптимизация контента
Материалы
Art Samples
Tutorials

Exporting 3D Models From Blender

This article describes how to export your 3D Model From Blender so that it would have proper scaling, position, and orientation when imported to UnigineEditor.

See Also#

Pre-Export Arrangement#

Before the export, do the following:

  • Check that Meters are set as working units.

    Blender scale should be: 1 unit = 1 meter.
    For convenience, you can set the grid cell size equal to 1 meter:
  • Orient the model towards the negative direction of the Y axis, which is the front direction in Blender.
  • Set the actual model size.
  • Apply All Transforms (Object -> Apply -> All Transforms).
    After applying all transforms a part of model can be misplaced due to complex parenting. In this case, first clear parent (Object -> Parent -> Clear and Keep Transform), then apply transforms, and finally restore parent, if necessary.
  • Check that materials are ready for export.

Export Settings#

As soon as your model is ready for export, click File -> Export -> FBX. Check that the parameters set in the Transform section are as follows:

Last update: 30.04.2020