[SOLVED] Using QT creator with unigine project


Recommended Posts

Hi everyone!

I try to make a unigine project with qt creator cause of qt's features that i need to use (e.g. webscokets and etr.). Now i choose "c++ qt based" in browser and get a project. But.

Compile procecess gives me pleanty of errors and base on this fact i want to ask a couple of questions.

1. Is there a tutorial how to use qt creator with unigine?

2. Maybe unigine works only with special qt version like for example 5.4 or something else.

I would glad to collet any information about this.

Thank you!

P.S. I use engineering kit on windows. 

Edited by kirill.melnikov
Link to post
On 2/22/2021 at 7:06 AM, silent said:

Hi Kirill,

We recommend to use Qt 5.12.3. Also, if you can show us the errors itself - it would be just great.


Hello Silent, thank you for the answer!

After that i fully reinstalled qt and specified version 5.12.3 with specifing MSVC2017 64 in qt project settings, compile process runs good but another one odd thing appears.

When I push the green button in qt creator, after compile process appears the application window but with a black background instead of my scene and only with a notice "not for commercial use and etr." in the left bottom corner. At the same time console does not appear. 

If I push the button "run" in the Unigine sdk browser, both (console and application windows appear and work fine. (like by using visual studio and run project under it).

Could be that i have to specify some special command line arguments or something else to prevent wasting time switching between browser and ide?))) 

Edited by kirill.melnikov
Link to post

Thank you and sorry for stupid questions! Now everyting works fine by me.



  • Thanks 1
Link to post
  • silent changed the title to [SOLVED] Using QT creator with unigine project