[SOLVED] Moving lights in the scene is really slow, keep getting the ''asset reimporting'' window after moving light


photo

Recommended Posts

Hi!

I am unable to properly do any kind of lighting due to this very annoying issue. Each time I move a light, the viewport becomes sluggish for a few seconds along with an asset reimporting popup. I have the same issue with light environments probes and that's even worse.

Also, another small issue, the mesh for the rectangular light gets rendered at runtime. That means that if I place a rect light near an emissive asset, it will reflect on the light's box mesh.

 

I really hope you guys can help me fix these issues, because I really enjoy working with this engine. 

 

Screen.jpg

Edited by NathanClarke
Link to post

Hi Nathan,

That's because your omni lights is set up as Static. In that case shadows are being regenerated each time you modify the light source parameters (including coordinates).

You can switch the light mode to Dynamic while you are working on the scene and then (when you will have the final picture) switch it again to static if required.

Thanks!

How to submit a good bug report
---
FTP server for test scenes and user uploads:

Link to post

Thanks for the answer! Actually, I just managed to fix the issues by disabling the automatic rebake options in the bake menu. But your technique is also working very well. :)

Edited by NathanClarke
  • Like 1
Link to post
  • silent changed the title to [SOLVED] Moving lights in the scene is really slow, keep getting the ''asset reimporting'' window after moving light