photo

Landscape and mask painting, cursor offset

Recommended Posts

Posted (edited)

Most of the time I experience an offset of the mousepointer and the tooltip on the mask/landscape

This doesnt feel very pleasant.

How can I solve this issues. Its somehow a collision/camera issue?

Best. Werner

m.jpg

Edited by werner.poetzelberger

Share this post


Link to post

Hi Werner,

How often does it happens? Could you please record a small video how to reproduce this behavior?

It doesn't look like DPI scaling is enabled in Display Settings, but to be 100% sure - could you please tell us your current Display Settings (resolution and DPI scale factor)?

Thanks!

Share this post


Link to post

I found out, that it come along the checkbox Intersection in the Landscape asset.

I switched that off so it causes these issuse.

On its kind of okay, the cursor stays almost all the time there where it should, but a lot of flickering.

I cant make a video atm. ;)

thx.

W.

Share this post


Link to post

But still something going weirdly wrong.

I try to paint now on a second layer.

When both are on, but I select the highest layer to paint on,

it as well paints on a second position.

It has something to do with this layers intersection, but I couldnt figure out, what exactly.

In this image.... I paint a detail (big spot) but it paints as well where the small spot is.

Thats soo weird.

 

 

two.PNG

Share this post


Link to post

It seems to work, when turning OFF the intersection for the highest layer.

Share this post


Link to post

Hello, Werner!

There was an know issue before 2.11.0.2 release, when intersection on brush was always triggered by highest layer, even when landscape layer map was completely turned off in world hierarchy.

Can you specify what exactly SDK you are using?

Thanks!

Share this post


Link to post

I actually will update now to 2.11.0.2

btw. How can I find out, precisely. The Editor splash is never updated withe correct version number and the log file doest show the proper version?

I am a bit confused. ;)

thx.w.

Share this post


Link to post
8 minutes ago, werner.poetzelberger said:

I actually will update now to 2.11.0.2

btw. How can I find out, precisely. The Editor splash is never updated withe correct version number and the log file doest show the proper version?

I am a bit confused. ;)

thx.w.

Yeah, splash and log only contains major release version and we have never update it for each following minor update cause of our internal reasons. Anyways it is already in TODO list and I hope it will be fixed soon. Yours actual version can always be viewed in SDK -> Projects list

Share this post


Link to post
Posted (edited)

Do you mean the SDK browser?

We dont use the browser, as we are updating core and bin folder regularlely.

 

Edited by werner.poetzelberger

Share this post


Link to post