FieldSpacer incorrect rendering


photo

Recommended Posts

Hello,

I have this very strange rendering  when using a FieldSpacer with a Water Global object with geodetic pivot.

image.png.425cd769474d735964c22598e111c8d5.png

The FieldSpacer has a scale of 1,1,1, size of 200,200,200, attenuation 1000. The spacer is actually in the far distance, but the cut behave like it is attached to the player.

The spacer is a child of the water, which is a child of the geodetic pivot.

Link to post

Amerio,

Currently FieldSpacer can work incorrectly with Geodetic  - that's known issue. We do not have plans to fix this immediately (due to already pretty busy schedule for the 2.8 and 2.9 releases), but if it's critical issue for your project we can try to raise priority for that task and fix it earlier (but some other features can be delayed as well that already planned).

Thanks!

How to submit a good bug report
---
FTP server for test scenes and user uploads:

Link to post

Hello,

Actually there was a incorrect code in my unigine script project.cpp. I had added "if (engine.editor.isLoaded()) return 1;" before callin engine.game.setPlayer, so it was never set. As far as I can tell, this was the only side effect.

Case closed.

Wrong again, the pb is still there. Driving me mad, but not important enough to justify a major slow down on your side. Can you anyway confirm or not the bug I mention is the same as the incompatibility you already know? 

Edited by Amerio.Stephane
Link to post

Hi Amerio,

Behavior that you captured on your screenshot is pretty much close to that one we found recently, so I assume that it's the same bugs. However, to be 100% sure a small test scene is required (not really need a terrain on it, unless it 100% required). Could you please see if you can provide a small reproducible test?

Thanks!

How to submit a good bug report
---
FTP server for test scenes and user uploads:

Link to post