UnigineEditor
Interface Overview
Settings and Preferences
Working With Projects
Adjusting Node Parameters
Setting Up Materials
Setting Up Properties
Landscape Tool
Using Editor Tools for Specific Tasks
Extending Editor Functionality
Programming
Fundamentals
Setting Up Development Environment
Usage Examples
UnigineScript
C++
C#
UUSL (Unified UNIGINE Shader Language)
File Formats
Rebuilding the Engine Tools
GUI
Double Precision Coordinates
API
Containers
Common Functionality
Controls-Related Classes
Engine-Related Classes
Filesystem Functionality
GUI-Related Classes
Math Functionality
Node-Related Classes
Objects-Related Classes
Networking Functionality
Pathfinding-Related Classes
Physics-Related Classes
Plugins-Related Classes
IG Plugin
CIGIConnector Plugin
Rendering-Related Classes

Exporting 3D Models From Maxon Cinema 4D

This article describes how to export your 3D Model From Maxon Cinema 4D so that it would have proper scaling, position, and orientation when imported to UnigineEditor.

See Also#

Pre-Export Arrangement#

Before the export, do the following:

  • Select Edit -> Preferences... and check that Centimeters are set as Unit Display.

    In the Project Settings, check that Centimeters are set as working units.

    In the Viewport options (Options -> Configure), Background tab, set the grid cell size of 1 meter for convenience.
  • Orient the model towards the negative direction of the Z axis.
  • Set the actual model size.
  • Freeze all transformations to avoid placement issues.
  • Check that materials are ready for export.

Export Settings#

As soon as your model is ready for export, click File -> Export... -> FBX.

In the Export Settings window, enable Normals and Triangulate Geometry.

Last update: 2020-04-30