UnigineEditor
Interface Overview
Settings and Preferences
Working With Projects
Adjusting Node Parameters
Setting Up Materials
Setting Up Properties
Lighting
Landscape Tool
Sandworm (Experimental)
Using Editor Tools for Specific Tasks
Extending Editor Functionality
Programming
Fundamentals
Setting Up Development Environment
Usage Examples
UnigineScript
C++
C#
UUSL (Unified UNIGINE Shader Language)
File Formats
Rebuilding the Engine Tools
GUI
Double Precision Coordinates
API
Containers
Common Functionality
Controls-Related Classes
Engine-Related Classes
Filesystem Functionality
GUI-Related Classes
Math Functionality
Node-Related Classes
Objects-Related Classes
Networking Functionality
Pathfinding-Related Classes
Physics-Related Classes
Plugins-Related Classes
IG Plugin
CIGIConnector Plugin
Rendering-Related Classes

Exporting 3D Models From Blender

This article describes how to export your 3D Model From Blender so that it would have proper scaling, position, and orientation when imported to UnigineEditor.

See Also#

Pre-Export Arrangement#

Before the export, do the following:

  • Check that Meters are set as working units.

    Blender scale should be: 1 unit = 1 meter.
    For convenience, you can set the grid cell size equal to 1 meter:
  • Orient the model towards the negative direction of the Y axis, which is the front direction in Blender.
  • Set the actual model size.
  • Apply All Transforms (Object -> Apply -> All Transforms).
    After applying all transforms a part of model can be misplaced due to complex parenting. In this case, first clear parent (Object -> Parent -> Clear and Keep Transform), then apply transforms, and finally restore parent, if necessary.
  • Check that materials are ready for export.

Export Settings#

As soon as your model is ready for export, click File -> Export -> FBX. Check that the parameters set in the Transform section are as follows:

Last update: 2020-04-30